ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Installing the fanuc_driver on fanuc crx robot

asked 2022-04-13 20:05:29 -0600

nizar00 gravatar image

updated 2022-04-15 01:11:47 -0600

gvdhoorn gravatar image

Hello, I m working on setting up the ROS Fanuc driver on CRX 10 Ia/L robot that has a R-30ib mini plus controller image description

Robot software is V9.40P22 image description

I used Roboguide to compile the binaries from the ros driver following the tutorial in this link : http://wiki.ros.org/fanuc/Tutorials/h...

image description

I can see the version of the robot software isn't in robo guide the closest I can find is v9.40p/23, my first question is will this cause a problem ?

Next, I loaded the programs in the controller according to the tutorial i can see them in the select program: Karel: image description

TP:

image description

But if run the TP programs I get these errors: ROS state:

image description

Ros :

image description

From the ROS troubleshooting, i can see its a configuration error i re did the setup step by step but still get these errors and i want to know where exactly is the issue and if there is any remedy

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-04-14 04:03:29 -0600

gvdhoorn gravatar image

updated 2022-04-14 04:04:48 -0600

Did you update the configuration of the Karel programs according to the values shown in the KAREL and TPE Programs: KAREL Programs section?

The tutorial in that section states:

The data in these two tables will need to be entered into the configuration structures of the respective programs.

and then provides instructions on how to do that.

If you did, please show a picture of the Karel Vars of both programs, specifically the contents of the cfg_ variables.

I can see the version of the robot software isn't in robo guide the closest I can find is v9.40p/23, my first question is will this cause a problem ?

No, that will not be a problem. The controller would have notified you if it was a problem (by refusing to load the .pc files completely).

edit flag offensive delete link more

Comments

image description

image description

is this correct ?

nizar00 gravatar image nizar00  ( 2022-04-14 05:48:04 -0600 )edit

That looks OK.

You just seem to have skipped/missed the Complete the Configuration step:

As the last step, complete the configuration by setting the checked entry in each of the configuration structures to TRUE.

gvdhoorn gravatar image gvdhoorn  ( 2022-04-14 05:58:07 -0600 )edit

thank you, the ROS tp worked, ros relay and ros state are showing some error but probably not related to this topic I will write another question if the errors keep persisting

nizar00 gravatar image nizar00  ( 2022-04-14 19:20:42 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-04-13 20:05:29 -0600

Seen: 246 times

Last updated: Apr 15 '22