Rosbridge subscribe: Unable to load the manifest for package

asked 2022-02-06 03:28:26 -0500

bela gravatar image

updated 2022-02-06 09:36:08 -0500

I have a robot that I display on the web. Unfortunately, a new virtual machine had to be created where the rosbridge server was not running. Throw in the next error you can see in the picture. I worked Ubuntu 18.04.

I run this:

roslaunch rosbridge_server rosbridge_websocket.launch

I get this:

image description

Many people on the internet have written to use devel / setup.bash before booting, but unfortunately it hasn't been good either. Thank you for your help!

edit retag flag offensive close merge delete


Probably dmw101 is the package you created. I think package.xml is not created yet.

miura gravatar image miura  ( 2022-02-06 16:33:14 -0500 )edit

the dwm1001 comes from a rosbag file, was it still created for me to bring her her package?

bela gravatar image bela  ( 2022-02-07 01:53:13 -0500 )edit

I think rosbridge can't process a topic recorded in rosbag unless it knows what type of message it is. Can't you try a different rosbag, or actually run it?

miura gravatar image miura  ( 2022-02-07 16:27:02 -0500 )edit