Ask Your Question
0

set_workspace moveit not working

asked 2021-12-09 10:00:29 -0500

Qualityland gravatar image

updated 2021-12-09 10:01:17 -0500

Hi friends,

I am working with MoveIt and Panda from Franka Emika. I am trying to set the workspace for the robot in Moveit to limit Joints Movement to avoid crashs. But it not seems to have any effekt to the robot.

Function is available for move_group in PythonAPI: https://github.com/ros-planning/movei...

My script looks like the following:

group = moveit_commander.MoveGroupCommander("panda_arm")

## [minX, minY, minZ, maxX, maxY, maxZ]
ws = [0.2, -0.3, 0.3, 0.7, 0.3, 0.7]
group.set_workspace(ws)

The script will fail due to an error if ws isn't well formed (e.g. ws with 7 entries) which tells me that I am doing the function-call correct ..

If there are other ways to limit joint movements (in Space), I appreciate any idea or hints.

Thanks a lot!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-12-09 10:27:28 -0500

Ranjit Kathiriya gravatar image

updated 2021-12-09 10:28:00 -0500

Hello Qualityland,

Have a look at this answer, #q273485 in short you cannot add revolutionary joints.

Instead, you can add a collision object to the region you want to avoid. you can have a look at moveit collision object adding or you can follow this answer #q209030.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-12-09 10:00:29 -0500

Seen: 46 times

Last updated: Dec 09 '21