...machine cannot connect to itself.

asked 2021-11-25 09:28:44 -0500

mikefw gravatar image

Distro: melodic Platform: Jetson Nano Linux: Ubuntu 18.04.6 LTS (bionic)

I am perpetually getting error: "Unable to contact my own server at []. " .... " A common cause is that the machine cannot connect to itself. " when I either try to launch a new package or even run roscore.

Regularly when I started up the Jetson it was issued with a new IP number by the local DHCP. I have now set both eth0 and wlan0 to static IPs, however this has not sorted out the problem.

I assume that this problem is associated with environmental variables, but I understand that it is inadvisable to adjust them manually. I have tried: source /opt/ros/melodic/setup.bash which I thought would reset the variables including the IP number, but: export | grep ROS still produces: ROS_IP="" ... not the current static IP.

I would much appreciate any help on this.

edit retag flag offensive close merge delete