Ask Your Question
0

Cannot find my ros package after successful built on raspberry pi 4

asked 2021-09-28 10:06:32 -0600

Uchiwuwu gravatar image

I installed ubuntu mate and then ros noetic on my raspberry pi 4. I built all of my packages with catkin_make, and it was successfully built. But when I run roscore and use rosrun, I couldn't find any packages I installed earlier, I even checked in dev and build file to see if those packages actually built and they were there. Then, I tried to create a simple package (hello_world) and it worked perfectly fine. Then, I installed those packages on my ubuntu laptop with the same ros noetic, and those worked fine too. I couldn't find any issue that makes those packages not able to run on raspberry pi 4.

Has anyone experienced this same issue before? What should i do to fix it?

edit retag flag offensive close merge delete

Comments

Have you sourced the package? What happens when you run rospack list

osilva gravatar image osilva  ( 2021-09-28 13:33:19 -0600 )edit

I did source the package, and the rospack didn't show my package either

Uchiwuwu gravatar image Uchiwuwu  ( 2021-09-28 19:59:55 -0600 )edit

Have you checked that path is correct in your ~/.bashrc? If rospack is not finding it looks sourcing might have been done incorrectly. Sometimes if you try too many times your ~/.bashrc might have errors. Can you show it to help troubleshooting

osilva gravatar image osilva  ( 2021-09-29 04:30:09 -0600 )edit

I sourced the path incorrectly in my /.bashrc. Thank you for your help

Uchiwuwu gravatar image Uchiwuwu  ( 2021-09-29 14:32:04 -0600 )edit

I will add as answer.

osilva gravatar image osilva  ( 2021-09-29 15:24:17 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-09-29 15:26:54 -0600

updated 2021-09-29 16:56:23 -0600

In most cases when you don’t find a package when running rospack list it’s that it has not been sourced correctly. Pls check your ~/.bashrc.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-09-28 10:06:32 -0600

Seen: 86 times

Last updated: Sep 29 '21