Ask Your Question
1

Gazebo (Fuerte on Ubuntu 12.04) returns "Invalid arguments"

asked 2012-07-12 03:09:01 -0500

NickVT gravatar image

updated 2012-07-18 05:47:14 -0500

hsu gravatar image

Dear all,

I tried to run the KUKA youbot simulation in Gazebo, with code that worked just fine under Electric on Ubuntu 11.04. But now I get this very meaningful error 'invalid arguments' without further indication where to look. Gazebo is not coming up. The mentioned log files are empty or don't exist. The output shows also an attribute error, which Gazebo gives also when launching the PR2 or an empty world (which didn't pose a problem for those simulations). If I delete the remap statements out of the launch file, I get a new error (see below), although the remap statement looks fine.

Anyone any idea? Did the syntax change?

Thanks in advance!

Nick

The launch script:

(if the launch script is not shown properly, you can find the full version here: https://github.com/youbot/youbot-ros-pkg/tree/master/youbot_common/youbot_description/launch/youbot_publisher.launch )

<code>
<launch>
        <param name="/use_sim_time" value="true" />
        <node name="gazebo" pkg="gazebo" type="gazebo" args="$(find gazebo_worlds)/worlds/empty.world" respawn="false" output="screen">
                <env name="GAZEBO_RESOURCE_PATH" value="$(find youbot_description):$(find gazebo_worlds):$(find gazebo)/gazebo/share/gazebo" />
                <remap from="base_controller/command" to="cmd_vel"/>
                <remap from="scan_front" to="base_scan"/>
                <remap from="/base_odometry/odom" to="/odom" />
        </node>

        <!-- send youbot urdf to param server -->
        <param name="robot_description" command="$(find xacro)/xacro.py '$(find youbot_description)/robots/youbot.urdf.xacro'"/>

        <!-- push robot_description to factory and spawn robot in gazebo -->
        <node name="youbot_gazebo_model" pkg="gazebo" type="spawn_model" args="-urdf -param robot_description -model youBot -x 0.0 -y 0.0 -z 0.1" respawn="false" output="screen" />

        <include file="$(find youbot_description)/launch/control/youbot_base_control.launch" />
        <include file="$(find youbot_description)/launch/control/youbot_arm_control.launch" />

</launch>
</code>

the output 
----------------
... logging to /home/u0065688/.ros/log/3df9c36e-cc1e-11e1-a6e5-0024e8dfc1df/roslaunch-pma-09-053-14267.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://localhost:54986/

SUMMARY


PARAMETERS
 * /arm_1/arm_controller/gains/arm_joint_1/d
 * /arm_1/arm_controller/gains/arm_joint_1/i
 * /arm_1/arm_controller/gains/arm_joint_1/p
 * /arm_1/arm_controller/gains/arm_joint_2/d
 * /arm_1/arm_controller/gains/arm_joint_2/i
 * /arm_1/arm_controller/gains/arm_joint_2/p
 * /arm_1/arm_controller/gains/arm_joint_3/d
 * /arm_1/arm_controller/gains/arm_joint_3/i
 * /arm_1/arm_controller/gains/arm_joint_3/p
 * /arm_1/arm_controller/gains/arm_joint_4/d
 * /arm_1/arm_controller/gains/arm_joint_4/i
 * /arm_1/arm_controller/gains/arm_joint_4/p
 * /arm_1/arm_controller/gains/arm_joint_5/d
 * /arm_1/arm_controller/gains/arm_joint_5/i
 * /arm_1/arm_controller/gains/arm_joint_5/p
 * /arm_1/arm_controller/joints
 * /arm_1/arm_controller/type
 * /base_controller/caster_joint_bl/position_controller/d
 * /base_controller/caster_joint_bl/position_controller/i
 * /base_controller/caster_joint_bl/position_controller/i_clamp
 * /base_controller/caster_joint_bl/position_controller/p
 * /base_controller/caster_joint_bl/velocity_controller/d
 * /base_controller/caster_joint_bl/velocity_controller/i
 * /base_controller/caster_joint_bl/velocity_controller/i_clamp
 * /base_controller/caster_joint_bl/velocity_controller/p
 * /base_controller/caster_joint_br/position_controller/d
 * /base_controller/caster_joint_br/position_controller/i
 * /base_controller/caster_joint_br/position_controller/i_clamp
 * /base_controller/caster_joint_br/position_controller/p
 * /base_controller/caster_joint_br/velocity_controller/d
 * /base_controller/caster_joint_br/velocity_controller/i
 * /base_controller/caster_joint_br/velocity_controller/i_clamp
 * /base_controller/caster_joint_br/velocity_controller/p
 * /base_controller/caster_joint_fl/position_controller/d
 * /base_controller/caster_joint_fl/position_controller/i
 * /base_controller/caster_joint_fl/position_controller/i_clamp
 * /base_controller/caster_joint_fl/position_controller/p
 * /base_controller/caster_joint_fl/velocity_controller/d
 * /base_controller/caster_joint_fl/velocity_controller/i
 * /base_controller/caster_joint_fl/velocity_controller/i_clamp
 * /base_controller/caster_joint_fl/velocity_controller/p
 * /base_controller/caster_joint_fr/position_controller/d
 * /base_controller ...
(more)
edit retag flag offensive close merge delete

Comments

I'm able to spawn the youbot model on it's own btw, using rosrun gazebo spawn_model -file /home/u0065688/src/svn/robotics-ros/packages/youbot-ros-pkg/youbot_common/youbot_description/robots/youbot.urdf -urdf -z 0.1 -model youBot

NickVT gravatar imageNickVT ( 2012-07-12 05:39:44 -0500 )edit

My question relates (I think) to the one posted on the ROS-users mailinglist (unanswered) :"Remap does not work on gazebo_ros_prosilica" on 24/6/2012

NickVT gravatar imageNickVT ( 2012-07-12 05:59:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-07-18 06:23:43 -0500

hsu gravatar image

updated 2012-07-18 07:49:39 -0500

Ticketed.

Yes, it's a problem with Fuerte that the gazebo node is no longer a ros node. The command line arguments needs to be passed in to underlying gazebo executable and passed through to the ros plugin that calls ros::init. I'll working on fixing this so namespace remapping works.

As a side note, I notice you are setting GAZEBO_RESOURCE_PATH in your launch file for the gazebo node; you can avoid doing so by updating manifest.xml in the youbot_description package to make sure it includes the following items:

<depend package="gazebo" />
<export>
  <gazebo gazebo_media_path="${prefix}/gazebo/share/gazebo-1.0.2" />
</export>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-12 03:09:01 -0500

Seen: 798 times

Last updated: Jul 18 '12