ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

ROS Warhouse on Noetic

asked 2021-09-09 04:22:10 -0600

zelix gravatar image

updated 2021-09-11 09:11:25 -0600

Mike Scheutzow gravatar image

I'm trying to use mongodb with rviz. Hence, i tried compiling warehouse_ros_mongo after doing a git clone to ~/catkin_ws/src folder . However, the cmake fails anyone has any idea on how to fix it. Otherwise, can some recommend a package to use with ros in order to connect the mongodb and interact with rviz/moveit.

Error encountered when compiling:

CMake Error at /home/zelix/catkin_ws/devel/share/warehouse_ros/cmake/warehouse_rosConfig.cmake:113 (message):
  Project 'warehouse_ros' specifies
  '/home/zelix/catkin_ws/src/warehouse_ros/include' as an include dir, which
  is not found.  It does neither exist as an absolute directory nor in
  '/home/zelix/catkin_ws/src/warehouse_ros//home/zelix/catkin_ws/src/warehouse_ros/include'.
  Check the website 'http://ros.org/wiki/warehouse_ros' for information and
  consider reporting the problem.
Call Stack (most recent call first):
  /opt/ros/noetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
  warehouse_ros_mongo/CMakeLists.txt:15 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/zelix/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/zelix/catkin_ws/build/CMakeFiles/CMakeError.log".
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-09-10 11:02:18 -0600

Mike Scheutzow gravatar image

You are aware that warehouse_ros and warehouse_ros_mongo are different ros packages? I am not sure, but it would not surprise me if you need both to make your own build.

Assuming you are on Ubuntu 20, why can't you install these using apt? Also, I believe it's also going to expect you to install a mongodb server (which is a non-ros thing) on your machine.

edit flag offensive delete link more

Comments

Yup so i did install mongodb. TI'm also aware that warehouse_ros and warehouse_ros_mongo are 2 different packages. So i tried to install `warehouse_ros_mongo' by doing a catkin_make but it fails.

When i was trying to do a catkin_make after cloning the warehouse_ros_mongo to ~/catkin_ws/src, That's when i encountered the error i mentioned above.

For the warehouse_ros i manged to do catkin_make successfully., however, when i referred to the tutorial i noticed that mongo_wrapper_ros.py no longer exists. Hence, tried running the C++ scripts on a standalone basis but it didn't work.

zelix gravatar image zelix  ( 2021-09-10 21:26:20 -0600 )edit
1

Is the error message correct for your computer? When I git-clone warehouse_ros, I see an include directory at the top level. Do you?

You have still not explained why you are making things harder for yourself by not using apt-get.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-09-11 07:05:29 -0600 )edit
1

FYI, In noetic, I cloned both ros packages, installed mongodb-dev, and ran catkin_make. It built successfully.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-09-11 07:26:39 -0600 )edit

Hi, just to clarify about apt-get do you mean that after i cloning, i do a sudo apt-get install make ?

I do see the include directory at the top level of warehouse_ros. I just manged to do a catkin_make with the warehouse_ros. Now how do i use it with my local instance of mongodb

zelix gravatar image zelix  ( 2021-09-11 08:06:35 -0600 )edit
1

The ubuntu package manager provides hundreds of ros packages ready for use. You don't need to clone the source code or compile if all you need is standard functionality. In this case you should have done:

sudo apt-get install ros-noetic-warehouse-ros
sudo apt-get install ros-noetic-warehouse-ros-mongo

and you would have been done.

Regarding your second question, the convention on this web site is "one question, one answer". After you do a search in the existing 60,000 questions, if you do not find an answer you are free to open a new question. You may include a url back to a previous question if that helps give context to your new question.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-09-11 08:42:22 -0600 )edit

Thank you very much!

zelix gravatar image zelix  ( 2021-09-11 20:29:55 -0600 )edit

I'm happy to help.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-09-12 08:31:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-09-09 04:22:10 -0600

Seen: 89 times

Last updated: Sep 10 '21