Joystick does not start collecting gps-waypoints!

asked 2021-08-24 10:25:53 -0500

Delbina gravatar image

updated 2021-08-24 10:26:29 -0500

hi everyone, I have connected a joystick, as I run: rostopic echo joy , it has output and works fine, now i want to use it for collecting the GPS waypoints, as I run: roslaunch outdoor_waypoint_nav joy_launch_control.launch , it asks for pressing LB key in order to collect waypoits, but as I press it no response from the joystick.

what is the problem? how can i fix it?


edit retag flag offensive close merge delete


as i press any button on my joystick, it doesnot do any of the following actions: Press LB to start waypoint collection Press RB to start waypoint following Press START to perform heading calibration Press B at ANY TIME to STOP robot motion

Would you please help me to solve this problem?

Delbina gravatar image Delbina  ( 2021-08-26 05:28:04 -0500 )edit

hi, my joystick does not show any response, why? can anybody help?

Delbina gravatar image Delbina  ( 2021-08-31 05:50:38 -0500 )edit