Ask Your Question
0

Ubuntu 12.04 ROS Fuerte Gazebo install Problem

asked 2012-07-09 10:13:08 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I have been trying to install ROS on several different computers now. I have also tried installing on multiple different Ubuntu systems, each time I get the following error when I try and start Gazebo using, roslaunch gazebo_worlds empty_world.launch.

process[gazebo_gui-3]: started with pid [16887]

/home/ncroscup/ros/simulator_gazebo/gazebo/scripts/gui: line 2: /home/ncroscup /ros/simulator_gazebo/gazebo/gazebo/bin/gzclient: No such file or directory

[empty_world_server-2] process has died [pid 16879, exit code 127, cmd /home/ncroscup/ros/simulator_gazebo/gazebo/scripts/gazebo /home/ncroscup/ros/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=empty_world_server __log:=/home/ncroscup/.ros/log/716587de-ca01-11e1-8ac1-90f652b11550/empty_world_server-2.log].

log file: /home/ncroscup/.ros/log/716587de-ca01-11e1-8ac1-90f652b11550/empty_world_server-2*.log

[gazebo_gui-3] process has died [pid 16887, exit code 127, cmd /home/ncroscup/ros/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/ncroscup/.ros/log/716587de-ca01-11e1-8ac1-90f652b11550/gazebo_gui-3.log].

log file: /home/ncroscup/.ros/log/716587de-ca01-11e1-8ac1-90f652b11550/gazebo_gui-3*.log

I followed instruction from the Ubuntu home site, http://www.ros.org/wiki/fuerte/Installation/Ubuntu

along with startup instructions of Gazebo from, http://www.ros.org/wiki/simulator_gazebo/Tutorials/StartingGazebo

I've looked for the errors and have come to the conclusion that it may be a driver issue, but I have tried several different video cards. Currently using Gefore 8600 GT, which is said to be compatible.

I'm starting to wonder if this actually works... should I downgrade to ros electric?

Very frustrated I've had to put so much time into this and still have no idea what to try next. It's been over a week of reinstalling on 3 different machines, and 5 different partitions... trying all possible issues I could think of... any suggestions? really would like to get this working.

edit retag flag offensive close merge delete

Comments

I doubt anyone will be able to help unless you post relevant parts of the error log. (Please format them with four leading spaces on each line.)

joq gravatar image joq  ( 2012-07-09 10:44:14 -0500 )edit
1

Im not really familiar with Gazebo or any of the issue you are having, so this may be a stupid comment. The line that says "....gazebo/bin/gzclient: No such file or directory" really stands out though. This looks like an executable. Is it there? Did Gazebo install correctly?

PerkinsJames gravatar image PerkinsJames  ( 2012-07-09 11:21:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-07-11 10:31:26 -0500

shuo gravatar image

hi, I think you did not install gazebo properly. Maybe you can go to Synaptic Package Manager to check if you have all of the gazebo related packages installed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-09 10:13:08 -0500

Seen: 758 times

Last updated: Jul 11 '12