ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Set velocity limit for Pilz Planner

asked 2021-07-08 07:31:57 -0600

anonymous user

Anonymous

updated 2021-07-08 07:33:58 -0600

Hi everyone,

i have an universal robot ur5e and can control it with ros+moveit. I use ompl or chomp for planning.

Now i want to try the Pilz planner, where problems begin. I install the Pilz planner package and copy the pilz_command_planner_planning_pipeline.launch.xml file in my launch directory. I can launch moveit with the pilz_command_pipeline, but while starting the error

Exception while loading move_group capability 'move_group/MoveGroupExecuteService': MultiLibraryClassLoader: Could not create object of class type move_group::MoveGroupExecuteService as no factory exists for it. Make sure that the library exists and was explicitly loaded through MultiLibraryClassLoader::loadLibrary()

appears. But at the end of booting i see:

[ INFO] [1625746415.465549752]: MoveGroup context using planning plugin pilz::CommandPlanner
[ INFO] [1625746415.465605026]: MoveGroup context initialization complete

You can start planning now!

Testing it with RViz, choosing PTP planner i got the error:

[ERROR] [1625746966.020478861]: velocity limit not set for group endeffector
[ERROR] [1625746966.020622564]: Exception caught: 'velocity limit not set for group endeffector'

Can anybody help me? I dont know where i can set the velocity limit. Changing the velocity in RViz doesn't help. In future i want to use python for control the robot using a script like this. But this doesn't work at all right now.

Thanks

edit retag flag offensive close merge delete

Comments

Hello, Have you solved the problem yet? Because I'm running into the same issue.

pitsai gravatar image pitsai  ( 2021-08-25 05:16:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-09-03 00:10:52 -0600

oscardev gravatar image

I had the same problem a few days ago, I solved it by modifying the joint_limits.yaml file inside of your *_movit_config/config package. Make sure that has_velocity_limits and has_acceleration_limits are true, here is a code snippet.

 joint_limits:
     elbow_joint:
         has_velocity_limits: true
         max_velocity: 3.15
         has_acceleration_limits: true
         max_acceleration: 3
edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2021-07-08 07:31:57 -0600

Seen: 472 times

Last updated: Jul 08 '21