Ask Your Question
0

How to select the Pilz Motion Planner?

asked 2021-06-24 06:27:50 -0500

anonymous user

Anonymous

Hello,

i use MoveIt with ROS Melodic and Ubuntu 18.04. At a first stage i install MoveIt with binary. But if i got it right, the Pilz Planner isn't a part of this installation. So i build MoveIt from source without problems in another workspace (does this matter?). But how can i select this planner? If i change the pipeline in my move_group.launch, i got an error:

MoveGroup running was unable to load pilz_industrial_motion_planner::CommandPlanner

i downloaded the pilz_industrial_motion_planner_planning_pipeline.launch.xml into my launch directory. But i don't know what i have to do in addition to get thinks work.

Thanks for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-06-24 10:00:34 -0500

pvl gravatar image

updated 2021-06-24 10:00:53 -0500

There is an apt package that contains the pilz motion planner. Install it with the following command:

sudo apt-get install ros-melodic-pilz-industrial-motion-planner
edit flag offensive delete link more

Comments

That makes life easier. I will try it. Thanks a lot!!

anonymous userAnonymous ( 2021-06-24 10:02:42 -0500 )edit
1

You are welcome ;). Let me know if it works and if it does please accept the answer to let others know that it works.

pvl gravatar image pvl  ( 2021-06-24 10:12:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-06-24 06:27:50 -0500

Seen: 168 times

Last updated: Jun 24 '21