ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

turtlebot3 bringup suddenly doesn't work

asked 2021-05-27 12:37:24 -0500

sudo-Boris gravatar image

updated 2021-05-29 03:41:55 -0500

I have worked with the turtlebot without issues, but at one seemingly random point I could not run the bringup of the turtlebot roslaunch turtlebot3_bringup turtlebot3_robot.launch

It stops at the following:


... logging to /home/ubuntu/.ros/log/86af288a-bf01-11eb-b39e-48b02d2b81aa/roslaunch-ubuntu-2658.log

Checking log directory for disk usage. This may take a while.

Press Ctrl-C to interrupt

Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://my_TURTLEBOT_IP:35829/

SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.11
 * /turtlebot3_core/baud: 115200
 * /turtlebot3_core/port: /dev/ttyACM0
 * /turtlebot3_core/tf_prefix: 
 * /turtlebot3_lds/frame_id: base_scan
 * /turtlebot3_lds/port: /dev/ttyUSB0

NODES
  /
    turtlebot3_core (rosserial_python/serial_node.py)
    turtlebot3_diagnostics (turtlebot3_bringup/turtlebot3_diagnostics)
    turtlebot3_lds (hls_lfcd_lds_driver/hlds_laser_publisher)

ROS_MASTER_URI=http://my_HOST_IP:11311   

process[turtlebot3_core-1]: started with pid [2667]    
process[turtlebot3_lds-2]: started with pid [2668]
process[turtlebot3_diagnostics-3]: started with pid [2669]

[INFO] [1622135149.303476, 0.000000]: ROS Serial Python Node
[INFO] [1622135149.398551, 0.000000]: Connecting to /dev/ttyACM0 at 115200 baud

Other post mentioned it was a battery issue. I charged my turtlebot3 up to full. Then the next bringup worked. But after that one bringup, it had the same error again, even after again charging those few percentages.

I have tried doing an apt-get update and upgrade -> still the same issue. What could it be? All the sudden stopped working..

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-30 11:46:07 -0500

sudo-Boris gravatar image

updated 2021-05-30 13:52:27 -0500

Rerunning the command rosrun turtlebot3_bringup create_udev_rules helps. Although it sometimes also doesn't. I ran this command on the one day, it worked. The day after: it didn't. Two days after that (today) it did work again.

You can give it a try.

Update: Not for long.. after the third bringup it again doesn't work..

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-05-27 12:37:24 -0500

Seen: 432 times

Last updated: May 30 '21