cartographer install on noetic and ubuntu focal

asked 2021-05-03 11:14:31 -0500

ros44 gravatar image

I have tried to install cartographer on Raspberry Pi 4 running Ubuntu focal and ROS noetic. Noetic is working so far on the Pi, and I have been able to control and display RPLidar output. Next step was to install cartographer. Followed the directions on page 3 of "Cartographer ROS Documentation" dated April 19, 2021.

After running the line: "catkin_make_isolated --install --use-ninja" I get CMake errors dealing with "Ceres" not found. The full result of the make and errors are below. I have found several online references to the same error but from four years ago with earlier versions of ROS. Tried all the suggested fixes with zero success. I have found no references online to the same issue with current noetic version.

I am at total loss what to try next.

So, my first question is - is there a better install process than the one described in the Cartographer ROS Documentation?

My second question is - am I better off by dropping back to an earlier Ubuntu release and trying all this over again with ROS Melodic?

Thanks for any suggestions and help. I am far from expert on Linux but can usually find enough hints online to muddle through. This one really has me stumped.

The full CMake results are:

ubuntu@ubuntu:~/catkin_ws$ catkin_make_isolated --install --use-ninja Base path: /home/ubuntu/catkin_ws Source space: /home/ubuntu/catkin_ws/src Build space: /home/ubuntu/catkin_ws/build_isolated Devel space: /home/ubuntu/catkin_ws/devel_isolated Install space: /home/ubuntu/catkin_ws/install_isolated ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~ traversing 16 packages in topological order: ~~ - cartographer (plain cmake) ~~ - cartographer_ros_msgs ~~ - cartographer_ros ~~ - cartographer_rviz ~~ - rplidar_ros ~~ - turtlebot3 ~~ - turtlebot3_description ~~ - turtlebot3_gazebo ~~ - turtlebot3_msgs ~~ - turtlebot3_bringup ~~ - turtlebot3_example ~~ - turtlebot3_fake ~~ - turtlebot3_navigation ~~ - turtlebot3_simulations ~~ - turtlebot3_slam ~~ - turtlebot3_teleop ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

==> Processing plain cmake package: 'cartographer' ==> cmake /home/ubuntu/catkin_ws/src/cartographer -DCMAKE_INSTALL_PREFIX=/home/ubuntu/catkin_ws/install_isolated -G Ninja in '/home/ubuntu/catkin_ws/build_isolated/cartographer/install' -- Build type: Release CMake Warning at /usr/src/googletest/googlemock/CMakeLists.txt:43 (project): VERSION keyword not followed by a value or was followed by a value that expanded to nothing.

CMake Warning at /usr/src/googletest/googletest/CMakeLists.txt:54 (project): VERSION keyword not followed by a value or was followed by a value that expanded to nothing.

CMake Error at /lib/cmake/Ceres/CeresConfig.cmake:88 (message): Failed to find Ceres - Ceres install root: /, determined from relative path from CeresConfig.cmake install location: /lib/cmake/Ceres, does not contain Ceres headers. Either the install directory was deleted, or the install tree was only partially relocated outside of CMake after Ceres was built. Call Stack (most recent call first): /lib/cmake/Ceres/CeresConfig.cmake:149 (ceres_report_not_found) CMakeLists.txt:39 (find_package)

CMake Error at CMakeLists.txt:39 (find_package): Found package configuration file:

/lib/cmake/Ceres/CeresConfig.cmake

but it set Ceres_FOUND to FALSE so package "Ceres" is considered to be NOT FOUND.

-- Configuring incomplete, errors occurred! See also "/home/ubuntu/catkin_ws/build_isolated/cartographer/install/CMakeFiles/CMakeOutput.log". See also "/home/ubuntu/catkin_ws/build_isolated/cartographer/install/CMakeFiles/CMakeError.log". <== Failed to process package 'cartographer': Command '['cmake', '/home/ubuntu/catkin_ws/src/cartographer', '-DCMAKE_INSTALL_PREFIX=/home ... (more)

edit retag flag offensive close merge delete