rviz crash at launch

asked 2021-12-30 00:15:58 -0500

updated 2022-01-02 07:27:36 -0500

osilva gravatar image

Hi I'm running ubuntu 20.04, ROS Noetic. when I run rivz it starts with the splash screen then crashes:

ubuntu@ubuntu:~$ rviz
[ INFO] [1640844436.990494049]: rviz version 1.14.11
[ INFO] [1640844436.990869727]: compiled against Qt version 5.12.8
[ INFO] [1640844436.990965633]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1640844437.028434376]: Forcing OpenGl version 0.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Segmentation fault (core dumped)

first time running Noetic. Any help would be greatly appreciated. Thanks

edit retag flag offensive close merge delete


Multiple previous answers on this same subject. Please do a search first and state what have you tried so far.

osilva gravatar image osilva  ( 2021-12-30 09:01:29 -0500 )edit

@osilva if a question is similar to others that have been answered you need to provide a link to the best of them. Closing should only be done if it's an exact match (especially from the same user)- and likely in that case there's a cause for deletion. Search queries may land here because of some unique phrasing or unique fragment of the error message or for any other odd reason beyond the control of this site, then there's nowhere to go, or worse because it's closed with no answer and no links it's more likely to result in a new similar question, or they won't even ask the question or use this site because they'll expect to get a low value 'go search for the answer' response when it was a search query that brought them here in the first place.

lucasw gravatar image lucasw  ( 2021-12-30 11:24:10 -0500 )edit

Hi @lucasw I understand and not trying to abuse closing questions. I raised an issue yesterday. Concern with RViz questions as I have seen they are use a bait to other sites:


osilva gravatar image osilva  ( 2021-12-30 11:27:27 -0500 )edit

I have searched extensively and find no matching config. I am running this on a raspberry pi 4 so updating the video driver for OpenGL is not as simple with no stand alone video card.

nickhulinsky@outlook.com gravatar image nickhulinsky@outlook.com  ( 2022-01-02 06:59:49 -0500 )edit

I reopened the question and added RPI tag.

osilva gravatar image osilva  ( 2022-01-02 07:29:06 -0500 )edit