"gazebo/clear_joint_forces" service doesn't work [closed]

asked 2012-07-01 23:39:08 -0600

Seungeun Lee gravatar image

updated 2012-07-01 23:43:59 -0600

i was following the tutorial titled "Gazebo ROS API for C-turtle". and there's part applying joint effort by using "apply_joint_effort" service(provided by "/gazebo" node) and clearing it back by "clear_joint_forces" service. Applying effort part was OK, but clearing it by "clear_joint_forces" service doesn't seem to work. it doesn't throw any error, it just silently pass through the "rosservice call gazebo/clear_joint_forces '{joint_name: link_joint}'" command and back to "#" command-line. And the cuboid in the simulator still spins. Any-body has the same problem?

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by tfoote
close date 2015-03-03 01:57:31.564953

Comments

It remains spinning probably because its inertia. Have you tried applying some counter forces?

tor gravatar image tor  ( 2012-07-02 01:18:29 -0600 )edit

yeah i tried applying counter force (negative effort)like "rosservice call gazebo/apply_joint_effort '{joint_name: link_joint, effort: -0.01, start_time: 10000000000, duration: 1000000000}'", and after applying the counter force the cuboid stop spinning.

Seungeun Lee gravatar image Seungeun Lee  ( 2012-07-03 03:22:28 -0600 )edit

tor, u mentioned that the reason why the cuboid remains spinning is probably due to its inertia~ but i still don't understand why clearing the force makes no difference in speed of the rotation. it seems that the cuboid spins at the same speed whether i clear the force or not.

Seungeun Lee gravatar image Seungeun Lee  ( 2012-07-03 03:36:34 -0600 )edit

Please ask gazebo questions at http://answers.gazebosim.org

tfoote gravatar image tfoote  ( 2015-03-03 01:57:26 -0600 )edit