fatal error while installing rtabmap_ros on ROS kinetic

asked 2021-03-12 04:26:08 -0500

Ayan gravatar image

am following your guide from:


and I am now installing rtabmap_ros but I am getting these error,

when I run the command

catkin_make -j1 I get this error

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkin_workspace.cmake:100 (message): This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation. Try the 'catkin_make_isolated' command instead. Call Stack (most recent call first): CMakeLists.txt:69 (catkin_workspace) -- Configuring incomplete, errors occurred! See also "/home/pi/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/pi/catkin_ws/build/CMakeFiles/CMakeError.log". make: [Makefile:1526: cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed*

after getting this error I run the command


as mentioned in the error

but this leads to this error

**In file included from /home/pi/catkin_ws/src/tf_conversions/eigen_conversions/src/eigen_kdl.cpp:30: /home/pi/catkin_ws/src/tf_conversions/eigen_conversions/include/eigen_conversions/eigen_kdl.h:40:10: fatal error: kdl/frames.hpp: No such file or directory

include <kdl frames.hpp="">

^~~~~~~~~~~~~~~~ compilation terminated. make[2]: * [CMakeFiles/eigen_conversions.dir/build.make:76: CMakeFiles/eigen_conversions.dir/src/eigen_kdl.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:402: CMakeFiles/eigen_conversions.dir/all] Error 2 make: [Makefile:141: all] Error 2 <== Failed to process package 'eigen_conversions': Command '['/home/pi/catkin_ws/devel_isolated/ddynamic_reconfigure/env.sh', 'make', '-j4', '-l4']' returned non-zero exit status 2

anyway to solve this problem ??

edit retag flag offensive close merge delete