Ask Your Question
0

Gazebo fails to load

asked 2012-06-25 06:58:55 -0500

natbur gravatar image

updated 2012-06-25 07:09:37 -0500

I've been trying to get ROS and Care-O-Bot installed and running for some time now. I can never get Gazebo to initialize properly. I'm using Ubuntu 10.04, and Fuerte

I start with the instructions here:
http://www.ros.org/wiki/fuerte/Installation/Ubuntu
http://www.ros.org/wiki/Robots/Care-O-bot/fuerte

Then these:
http://www.ros.org/wiki/cob_bringup_sim

I can get through all of the ROS tutorials, so I believe that everything has been done correctly with respect to ROS, but when I run cob_bringup_sim Gazebo fails with the following error:

Error [Plugin.hh:100] Failed to load plugin -1: -1: cannot open shared object file: No such file or directory
Warning [parser.cc:332] Gazebo SDF has no gazebo element
Warning [parser.cc:243] parser for sdf version 1.0 failed, trying to parse as old deprecated format
Segmentation fault

For reference, here is the Gazebo cmd that cob_bringup_sim generates, running this line solo creates the same error:
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo -s -1 /opt/ros/fuerte/stacks/cob_environments/cob_gazebo_worlds/common/worlds/empty.world __name:=gazebo __log:=/home/nathan/.ros/log/58188a6e-bee5-11e1-bd07-f46d0412dc71/gazebo-2.log

No log file is generated, and I can only assume that Gazebo never even attempts to load.

edit retag flag offensive close merge delete

Comments

what file is missing ?? i think there should be any .so file or so by: Error [Plugin.hh:100] Failed to load plugin -1: -1: cannot open shared object file: No such file or directory

pkohout gravatar imagepkohout ( 2012-07-10 20:10:49 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-08-08 02:54:11 -0500

natbur gravatar image

It seems to stem from the combination of Fuerte and COB. As soon as I rolled back to Electric, everything started working. Not sure if something has changed in the format of the simulation files for Fuerte that makes the current COB code not work, but for now I'm just sticking to Electric.

edit flag offensive delete link more
0

answered 2012-08-08 08:50:24 -0500

Jakub gravatar image

There is an issue with the your launch file

gazebo -s <plugin_name>

So in your case gazebo tries to load a plugin called -1.

I believe you wanted to make inital position for the robot and you meant:

gazebo -x -1 <world_file>

Check your launch file for misspelling.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-06-25 06:58:55 -0500

Seen: 634 times

Last updated: Aug 08 '12