Ask Your Question
0

Cannot locate rosdep definition for [qt4]

asked 2012-06-19 11:41:11 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I m trying to use Rgbdslam on Ubuntu 12.04 LTS and ROS Fuerte however I am a beginner in ROS and I can't figure it out how to make that work.

I did tthe followings steps :

1) Installed Ubuntu 12.04 LTS 64bit version

2) Installed ROS Fuerte (sudo apt-get install ros-electric-fuerte-full)

3) echo "source /opt/ros/electric/setup.bash" >> ~/.bashrc

4) . ~/.bashrc

5) Installed QT Creator via Ubuntu Software Center

4) Setup RGBDSLAM again as per http://www.ros.org/wiki/rgbdslam

a. mkdir -p ~/ros

b. echo 'export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH' >> ~/.bashrc

c. source ~/.bashrc

d. svn co http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam

e. svn co https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/g2o ~/ros/g2o

f. rosdep install rgbdslam

And it failed directly :

alban:~/ros$ rosdep install rgbdslam
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rgbdslam: Cannot locate rosdep definition for [qt4]

I suppose that I don't just have to install QT Creator, maybe I have to do some more stuff but I didn't success to find this information. Does anyone can help me ?

[ I ve tried also to install the advices following librairies : "sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev"

No problem And when I type

alban:~/ros$ update-alternatives --display qmake

I get:

qmake - mode automatique
 le lien pointe actuellement sur /usr/bin/qmake-qt4
/usr/bin/qmake-qt4 - priorité 40
 lien secondaire qmake.1.gz : /usr/share/man/man1/qmake-qt4.1.gz
La « meilleure » version actuelle est « /usr/bin/qmake-qt4 ».

]

I tried to compile directly:

alban:~$ rosmake rgbdslam
[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['rgbdslam']                                
[ rosmake ] Logging to directory /home/alban/.ros/rosmake/rosmake_output-20120620-124759
[ rosmake ] Expanded args ['rgbdslam'] to:
['rgbdslam']                         
[rosmake-0] Starting >>> bullet [ make ]                                        
[rosmake-1] Starting >>> geometry_msgs [ make ]                                 
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet                   
[rosmake-1] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
[rosmake-0] Starting >>> roslang [ make ]                                       
[rosmake-1] Starting >>> sensor_msgs [ make ]                                   
[rosmake-0] Finished <<< roslang  No Makefile in package roslang                
[rosmake-0] Starting >>> roscpp [ make ]                                        
[rosmake-1] Finished <<< sensor_msgs  No Makefile in package sensor_msgs        
[rosmake-1] Starting >>> rosconsole [ make ]                                    
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-0] Starting >>> angles [ make ]                                        
[rosmake-1] Finished <<< rosconsole  No Makefile in package rosconsole          
[rosmake-1] Starting >>> rospy [ make ]                                         
[rosmake-0] Finished <<< angles ROS_NOBUILD in package angles                   
[rosmake-0] Starting >>> rostest [ make ]                                       
[rosmake-1] Finished <<< rospy  No Makefile in package rospy                    
[rosmake-1] Starting >>> roswtf [ make ]                                        
[rosmake-1] Finished <<< roswtf  No Makefile in package roswtf                  
[rosmake-1] Starting >>> message_filters [ make ]                               
[rosmake-1] Finished <<< message_filters  No Makefile in package message_filters
[rosmake-0] Finished <<< rostest  No Makefile in package rostest                
[rosmake-0] Starting >>> std_msgs [ make ]                                      
[rosmake-1] Starting >>> tf [ make ]                                            
[rosmake-1] Finished <<< tf ROS_NOBUILD in package tf                           
[rosmake-1] Starting >>> rosbag [ make ]                                        
[rosmake-1] Finished <<< rosbag  No Makefile in package rosbag                  
[rosmake-0] Finished <<< std_msgs  No Makefile in package std_msgs              
[rosmake-0] Starting >>> pcl [ make ]                                           
[rosmake-1] Starting >>> rosbuild [ make ]                                      
[rosmake-1] Finished <<< rosbuild  No Makefile in package rosbuild              
[rosmake-1] Starting >>> roslib [ make ]                                        
[rosmake-1] Finished <<< roslib  No Makefile in package roslib                  
[rosmake-1] Starting >>> pluginlib [ make ]                                     
[rosmake-1] Finished <<< pluginlib ROS_NOBUILD in package pluginlib             
[rosmake-0] Finished <<< pcl  No Makefile ...
(more)
edit retag flag offensive close merge delete

Comments

Did you installed Qt4 libraries? I do not know whether these gets installed as dependency packages for QT Creator! Check for correct version of Qt libraries.

prince gravatar imageprince ( 2012-06-19 17:37:42 -0500 )edit

I think that I have installed QT4 libraries by doing this : alban:~$ sudo apt-get install libqt4-dev Reading package lists... Done Building dependency tree
Reading state information... Done libqt4-dev is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgrad

Absy gravatar imageAbsy ( 2012-06-20 00:33:31 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2012-06-20 00:25:07 -0500

Lorenz gravatar image

updated 2012-06-20 01:10:10 -0500

Probably, the rosdep definition for qt4 is not defined for fuerte yet. That's not a fatal error though. Just ignore the rosdep install step and continue with building the rgbdslam stack.

It seems to me that the stack hasn't been ported to Fuerte yet since the rosdep definition for qt4 is unknown. That means there is a certain chance that you will run into compile problems.

Edit: Running rgbdslam is not working because you got a build error. As I said, rgbdslam doesn't seem to be ported to Fuerte yet. I actually suggest using Electric for now. The reason for the actual error you see is that eigen is no ros package anymore but a system dependency. You can try removing the dependency on it from rgbdslam's manifest.xml file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-06-19 11:41:11 -0500

Seen: 3,272 times

Last updated: Jun 20 '12