Error message [1607310726.052916]: Tried to publish before configured, topic id 101

asked 2020-12-06 23:55:28 -0500

muppetfish gravatar image

Hi everyone!

I'm a new ROS user trying to get communication between a RPi4 and a VEX V5 brain. I'm trying to set up a subscriber node in my .cpp file to receive data from the Twist message.

I've already got a subscriber working for String which displays a message on the VEX LCD when published manually with rostopic pub. However, trying to publish anything with turtlesim and teleop_key results in no response from the brain, and the error:

"[1607310726.052916]: Tried to publish before configured, topic id 101" the /chatter topic whenever a key is pressed and the teleop_node/turtlesim is running.

I've tried running the node through the dedicated PROS workspace as well as vanilla rosserial, same error repeats.

Does anyone have an idea of what causes this/how to correct it, so I can display the cmd_vel data on the LCD the same as I did with the String message?

I can supply code/rqtgraphs/screenshots if needed. Apologies if poor formatting, first time poster!

Thanks in advance!

edit retag flag offensive close merge delete