Ask Your Question
0

openai_ros on Ubuntu Focal + ROS Noetic

asked 2020-12-02 09:59:17 -0500

KinWah gravatar image

Just would like to have a quick check, is it possible to use openai_ros with ubuntu focal + ros noetic? the reason I am asking this is I get the following error while trying the last step of the instruction mentioned at here (https://bitbucket.org/theconstructcor...).

kinwah@ROS:~/catkin_ws$ rosdep install openai_ros

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:

openai_ros: No definition of [python-catkin-pkg] for OS version [focal]

If it is not possible, anyone knows how to resolve this or how can I approach the maintainers for possible workarounds?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2020-12-03 04:48:49 -0500

KinWah gravatar image

Hi everyone! I have gotten in touch with the maintainer team of openai_ros! According to the email reply, there will be support for Noetic at the beginning of next year. Also for ROS2.

edit flag offensive delete link more

Comments

Still having this issue, has there been any news?

Bax gravatar image Bax  ( 2021-01-20 01:36:19 -0500 )edit
0

answered 2021-02-28 19:21:25 -0500

Barikata1984 gravatar image

Hi, I could solve the issue by changing a line in "your_ws/src/openai_ros/openai_ros/package.xml."

I guess that you can find the code <build_depend>python-catkin-pkg</build_depend> on line 14 or around it. Although Noetic works on Python3 basically, this code declares catkin-pkg for python2. So, I changed the code to <build_depend>python3-catkin-pkg</build_depend> or <build_depend>python3-catkin-pkg-modules</build_depend>. Sorry for the vagueness since it has been a while since I dealt with it. But, either, or both, of them worked well for me. I hope it is also the case for you.

edit flag offensive delete link more
0

answered 2021-01-20 03:14:28 -0500

RDaneelOlivaw gravatar image

Hi,

I just tested to download the fetch simulation and execute an example for fetch robot and worked in ROS Noetic. This is one of the exercises in the course of Openai_ROS: OPENAI_ROS course. There is everything ready to go. The noetic version will be there in the next week form writing this post. The procedure I followed:

1) Setup in Ubuntu20 ROS Noetic and create a catkin_ws.

2) Inside it downloaded the packages relevant for your sim

3) Compiled through catkin_make 4) Installed needed dependencies. The relevant for Openai_ros are:

    pip3 install --ignore-installed \
tensorflow \
gym \
wandb \

You might have to install other ROS related packages depend on what you need

5) Execute you open ai Algorithm.

image description

edit flag offensive delete link more
0

answered 2020-12-02 10:16:16 -0500

updated 2020-12-02 10:17:11 -0500

You should be able to download the source and build. As the readme says, clone the repo into your workspace and build the package using catkin build openai_ros (or catkin_make openai_ros depending on your toolset). I was able to build in bionic/melodic.

rosdep will probably need the specific version of ubuntu+ros installed. If you run into missing packages errors, you can install them manually using apt install ros-noetic-<package>

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2020-12-02 09:59:17 -0500

Seen: 338 times

Last updated: Jan 20