Ask Your Question
0

noetic mavros rqt_runtime_monitor reports Failure to connect to FMU, Raspberry Pi 4b to PX4 (Pixhawk) on Ubuntu 20.04

asked 2020-10-16 19:38:20 -0600

Aaron_Sims gravatar image

Noetic mavros rqt_runtime_monitor reports Failure to connect to FMU, Raspberry Pi 4b to PX4 (Pixhawk) on Ubuntu 20.04. I’ve spent a couple weeks trying everything I can think of to get mavros working on rpi4b running Ubuntu 20.04. I can successfully start mavros without any errors, however it seems I am not receiving any data from the PX4 unit. Rqt_runtime_monitor says it could not connect to the fmu but it starts okay. Everything should be connecting on the /dev/serial0 port to the telem 2 pixhawk connection. of course every video example online makes it look easy and like it’s not a problem but I’ve noticed also that they seem to only use USB. Anybody who’s done this before I would appreciate your help. Like how do I check if the serial Port is actually sending and receiving data?

Thanks,

Aaron

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-03-05 16:40:32 -0600

Aaron_Sims gravatar image

Common Sense lesson when working with serial ports. If you spent an extensive amount of time trying to figure out what's wrong and you wired them yourself make sure that the TX wire is going to the RX wire and not the TX wire. Lol. Sounds like such a dumb mistake and it is but I wasted a week trying to come up with a solution software and every other way until I just broke it down and I realized all of the pins were transmitting correctly the power was there and some guy on a forum asked a guy with same problem if tx was going to rx or tx, and I thought to myself dude would I possibly make that mistake and then I was just like oh my goodness I checked it and sure enough I miswired it. That's equivalent to the service call where you show up and you ask them is your PC plugged in? They argue with you they say of course it is don't check it and you check it anyways and their PC is unplugged 😂 it happens to us all I think (burst my bubble if I'm alone;) I restarted my computer and mavros worked immediately on serial0. it's been so long since I worked on serial ports I forgot the basic rules if it doesn't work it's the most basic thing it's probably not a software issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-10-16 19:38:20 -0600

Seen: 147 times

Last updated: Mar 05