rosbag record isn't recording everything being published on topic

asked 2020-09-08 13:59:31 -0600

sbrentphysics gravatar image

Hi,

I am trying to record one topic in a rosbag using rosbag record, however I can see using rostopic echo /topic that my simulation is publishing on the topic correctly.

When I look in the rosbag using rqt_bag file.bag I can see that it has missed a lot of the data that it was supposed to record.

I already looked at a previous users post regarding a similar problem where they change /use_sim_time from true to false, however that hasn't resolved my problem. I also tried to increase the rosbag buffer size, which also doesn't work.

Appreciate any help or suggestions.

edit retag flag offensive close merge delete

Comments

@sbrentphysics Have you tried rosbag record -a to record all available topics? Everytime rosbag record is called, the program prints the set of topics that it is reading and storing, maybe you wrote a bad name or forgot a namespace.

Weasfas gravatar image Weasfas  ( 2020-09-09 04:47:35 -0600 )edit

yes, I have tried that, it's still not recording all the messages that its receiving. I am able to see the topics are being published but the bag is only recording them partially.

sbrentphysics gravatar image sbrentphysics  ( 2020-09-09 09:53:58 -0600 )edit

Have you tried rosbag record --buffsize=0 for buffering up messages?

KenYN gravatar image KenYN  ( 2020-09-09 20:38:54 -0600 )edit