ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

rqt_plot not showing data while using rosbags

asked 2020-07-08 07:46:31 -0600

SK gravatar image

updated 2022-05-23 09:23:04 -0600

lucasw gravatar image

Hello everyone,

I have a question regarding rqt_plot. The problem is that rqt_plot is not showing the data which is published by a node, but I can see the published data when I run rostopic echo <topic_name>

I think I am doing something wrong with the sim_time, but I am not sure what is wrong. Here is what I am doing:

  1. $roscore
  2. $rosparam set use_sim_time true
  3. $rosbag play --clock <filename>.bag
  4. $rosrun <package> <executable>
  5. Start rqt_plot

Am I missing a step or something?

Thank you very much in advance!

Best regards

edit retag flag offensive close merge delete

Comments

Hi @SK,

For what I understand from the set of commands you posted is that you are trying to plot a topic produced by the Node launched at step 4.; not a topic from a Rosbag. If I am mistaken please correct me. However, if that is the case, setting sim_time parameter a true and trying to plot a value produced with a Node in actual time maybe be the reason why you cannot see the the info plotted.

Weasfas gravatar image Weasfas  ( 2020-07-08 08:37:53 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-08 08:37:32 -0600

SK gravatar image

Okay I just fixed it.. Problem was that the node was publishing the geometry_msgs/PoseStamped with an wrong Time stamp.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-07-08 07:46:31 -0600

Seen: 106 times

Last updated: Jul 08 '20