Virtual Machine usb_cam pkg, When I run two camera in same time it returns me Device Busy for one node, Why?

asked 2020-06-13 07:45:24 -0500

KOMODO gravatar image

updated 2020-07-03 11:44:45 -0500

Hi all robotters. I am using usb_cam pkg. I used on my Raspi3B+. I installed ubuntu 18.04 image on it. My launch file for usb_cam worked properly. But I did not calibrated my cams very well because it was so slow.

So i installed Virtual Machine. I installed Ros industrial demo image. And i installed usb_cam on it. usb_cam works very well for one camera. But If i use another terminal or a launch file i get errors. It returns me Device Busy. But the problem is my OS shows me two video devices.

$: ls /dev/video*

returns me video0 and video1. So i pass them into a launch file. Roscore is running allways. Even i use two terminal like:

$: rosrun usb_cam usb_cam_node video:=/dev/video0  --> Terminal 1
$: rosrun usb_cam usb_cam_node video:=/dev/video1  --> Terminal 2

When i run second terminal it returns me device busy error.

This video is what i did: https://filebin.net/35p9mai7p36ful0h

Anyone Help ME? What's wrong? :(

edit retag flag offensive close merge delete

Comments

Could you provide your console output too. Also you can investigate which process is using your device by using fuser /dev/videoX command.

bay gravatar image bay  ( 2020-06-23 03:23:56 -0500 )edit

https://filebin.net/35p9mai7p36ful0h

You can look at my ops in this video.

KOMODO gravatar image KOMODO  ( 2020-07-03 11:44:02 -0500 )edit