Ask Your Question
0

TurtleBot3 Home Service Challenge costmap issue

asked 2020-06-01 04:22:58 -0500

anonymous user

Anonymous

updated 2020-06-01 04:55:41 -0500

Hello everyone!

I have problems with the TurtleBot3 Home Service Challenge (http://emanual.robotis.com/docs/en/pl...). I've installed everything according to the tutorial on the website, and performed the three calibrations/setup steps (camera calibration, intrinsic camera calibration and SLAM room mapping).

Then, when I want to launch the actual "program", I get the following error in the terminal:

[ WARN] [1589895191.142389918]: Timed out waiting for transform from tb3_hsc/base_footprint to map to become available before running costmap, tf error : canTransform: target_frame map does not exist.. canTransform returned after 0.100373 timeout was 0.1

The weird thing is that the regular manipulation navigation (http://emanual.robotis.com/docs/en/pl...) works fine. When I launch that one, the costmap is pretty much instantly generated and shown in Rviz. Furthermore, giving the TB3 navigation goals works fine.

I've tried to debug the problem and found a difference between the regular manipulation navigation and the HSC navigation, using the rqt_graph command. This difference can be shown in the image below: image description

I've also opened an issue tracker on GitHub (https://github.com/ROBOTIS-GIT/turtle...), but there has not been a working solution given there. I hope someone here can help me, as I need this to work for my project.

If you need any additional information to solve the issue, please let me know and I'll do my best.

Edit: Just another (perhaps interesting) piece of information is that I can manipulate the OpenMANIPULATOR-X without any issues. So the program isn't completely broken. Just the navigation part doesn't work, due to the lack of a costmap.

edit retag flag offensive close merge delete

Comments

I'm sorry to have to do this for something so seemingly unimportant, but please don't post screenshots of terminal text in question on ROS Answers. It's all text, so there is no need. Just copy-paste the text from the terminal into your question text. Do make sure to format it properly by selecting the text and pressing ctrl+k (or clicking the Preformatted Text button (the one with 101010 on it)).

You don't need to post a new question, just edit your curent one. You can use the edit button/link for this.

After you replace the screenshot with the error message itself, we can re-open your question.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-01 04:29:42 -0500 )edit

@gvdhoorn Sorry, you're completely right. I've updated my post to follow the guidelines.

anonymous userAnonymous ( 2020-06-01 04:41:31 -0500 )edit

I don't know whether it matters, but there appears to be an additional space after the name of the frame:

Timed out waiting for transform from tb3_hsc/base_footprint  to map to become available

Notice the extra whitespace between tb3_hsc/base_footprint and the word to.

I haven't checked whether that is introduced by the ROS_WARN(..) used there (or the string passed to it by the code), but it may be something to check. tb3_hsc/base_footprint would not be the same as tb3_hsc/base_footprint (there is an additional space there, it's just not rendered by AskBots HTML).

gvdhoorn gravatar image gvdhoorn  ( 2020-06-01 04:52:32 -0500 )edit

@gvdhoorn That's been a mistake I made while copying the error, sorry. I've fixed the code in my post. So this extra space does not appear in the actual error message.

anonymous userAnonymous ( 2020-06-01 04:56:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-04 04:20:34 -0500

anonymous user

Anonymous

I solved the issue. My environment was not exactly the same as when I generated the SLAM map (small things like chairs, open/closed door, etc. can apparently make quite the difference). When I didn't change my environment between the SLAM mapping and the HSC, there were no longer problems.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-06-01 03:48:30 -0500

Seen: 47 times

Last updated: Jun 04