Ask Your Question
0

Filter trajectory fails in warehouse viewer

asked 2012-05-30 05:28:42 -0600

Filtering a trajectory in the arm warehouse viewer (Fuerte, Ubuntu 11.10) fails for an unknown reason

Using ROS-Industrial ( https://swri-ros-pkg.googlecode.com/svn/trunk )

roslaunch sia10d_mesh_arm_navigation planning_scene_warehouse_viewer_sia10d_mesh.launch

Steps to reproduce:

  1. Select a "new motion plan request" from planning scene warehouse viewer window
  2. Select "Interact" in Rviz and move the robot to a new position
  3. Select "plan a new trajectory" from the planning scene warehouse viewer window
  4. Select "filter trajectory" from the planning scene warehouse viewer window.

The Trajectory filter fails for an unknown reason. An error message is not generated (at least not in rxconsole). An info message from the planning_scene_warehouse node is generated. Sometimes the filter node crashes completely.

The filter fails on all of the arm_navigation packages in ROS-Industrial.

Is this a bug, or am I doing something wrong?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-31 06:16:51 -0600

egiljones gravatar image

I just released a fix - an intern added the option to use different trajectory filters, and renamed the parameter trajectory_filter_service_name to trajectory_filter_1_service_name, and I changed it back. You can either wait for debs to get built and show up or manually edit your launch file in the meantime.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-30 05:28:42 -0600

Seen: 124 times

Last updated: May 31 '12