Ask Your Question
0

How to fix SIA10D ROS industrial robot loading model fail in RViz?

asked 2012-01-31 19:54:51 -0500

sam gravatar image

updated 2012-02-01 16:29:12 -0500

I followed ROS-Industrial Tutorial.

I run:

  roslaunch sia10d_mesh_arm_navigation planning_scene_warehouse_viewer_sia10d_mesh.launch

And get partly loaded model of motoman robot.

image description

How to fixed it?

Thank you~

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-02-02 05:26:35 -0500

The problem you are seeing occurrs when the tf node is not generating the link transforms. This occurs because this node is probably not started yet. One reason can be that the warehouse planning configuration has not been accepted (the Rviz window sometimes hides the configuration dialogue when it starts up.

  1. Select the planning scene warehouse viewer window (see below) image description
  2. Accept the default configuration image description
  3. The rest of the application should load correctly.

If this doesn't solve your problem, then you might not have the correct ROS libraries installed. Please include the roslaunch output if this procedure doesn't work for you.

edit flag offensive delete link more

Comments

Yes,thank you~ I solve it! I found that I should click accept and "close warehouse_viewer again" to let warehouse_viewer show normal interface and RViz will become normal robot model.
sam gravatar image sam  ( 2012-02-02 19:44:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-31 19:54:51 -0500

Seen: 354 times

Last updated: Feb 02 '12