the set_command service failed when running the node tracker_base_controller in the package "pi_tracker" [closed]

asked 2012-05-29 17:47:09 -0600

sven_007 gravatar image

updated 2012-05-29 20:30:48 -0600

  1. At first,I run "roslaunch pi_tracker skeleton.launch" on the command line.And then the topic "/skeleton" came out.So I run "rosrun pi_tracker tracker_base_controller.py" on the command line.And then the the topic "/cmd_vel" came out.But the messages on the topic "/cmd_vel" is always like this: linear: x: 0.0 y: 0.0 z: 0.0 angular: x: 0.0 y: 0.0 z: 0.0

  2. So I call the service "set_command",and then the window running the node "tracker_base_controller" shows as below:

    "Traceback (most recent call last): File "/home/sven/ros_workspace/pi_tracker/bin/tracker_base_controller.py", line 254, in <module> TrackerBaseController() File "/home/sven/ros_workspace/pi_tracker/bin/tracker_base_controller.py", line 82, in __init__ if self.tracker_command == 'STOP' or (self.skeleton['confidence']['left_hand'] < 0.5 and self.skeleton['confidence']['right_hand'] < 0.5): KeyError: 'left_hand' [INFO] [WallTime: 1338390962.048561] Shutting down Tracker Base Controller Node." Obviously,the node "tracker_base_controler" stopped running. Is there any one who can help me?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-03-03 01:47:16.794190