Ask Your Question
0

Problem running Teleoperation Package

asked 2013-03-18 22:50:32 -0500

Rizqa gravatar image

updated 2016-10-24 09:01:15 -0500

ngrennan gravatar image

Hi.. I try to move ax12 dynamixel servo by using kinect in Skeleton Tracker Teleoperation Package for Mobile Robot..

http://www.ros.org/wiki/openni/Contests/ROS%203D/Skeleton%20Tracker%20Teleoperation%20Package%20for%20Mobile%20Robot

I have launched skeleton.launch, tracker.launch, robotis.launch, dynamixels.launch but my servo motor don't move at all..

Do I have to add new node for subscribing skeleton joint and publishing it to my servo ?

Thanks for your time..

edit retag flag offensive close merge delete

1 Answer

Sort by ┬╗ oldest newest most voted
0

answered 2013-03-19 06:12:44 -0500

Zab gravatar image

Hi, I had the same issue which was solved by setting use real robot to true in the tracker_params.yml file. pi_tracker/params/tracker_params.yml

Hope it helps.

edit flag offensive delete link more

Comments

Hi @Zab

of course.. I have set use_real_robot to true in the tracker_params.yml file.. but My servo don't move.. -__- How could this problem solve @Zab ??

Rizqa gravatar image Rizqa  ( 2013-03-19 19:03:11 -0500 )edit

Check the baudrate that is being used for robotis_params. Try 1000000.

Zab gravatar image Zab  ( 2013-03-20 09:40:19 -0500 )edit

hi @Zab

I found the problem in command_rate, tracking_rate, joint_controller_rate in tracker_params.yaml file.. :) it works fine.. Thanks @Zab.. for your time..

Rizqa gravatar image Rizqa  ( 2013-03-20 17:11:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-18 22:50:32 -0500

Seen: 107 times

Last updated: Mar 19 '13