Ask Your Question
0

Directory 'c:\opt\chocolatey\lib' does not exist.

asked 2020-05-10 21:08:02 -0600

metobodrum gravatar image

updated 2020-05-12 19:41:09 -0600

Hello,

I'm trying to install ROS for the first time. I have been following the guidelines for installing ROS on Windows, at the link provided below.

http://wiki.ros.org/Installation/Windows

I have installed the Visual Studio 2019 successfully with "Desktop development with C++" workload prior to running the command prompt. After I have run the command for installing Chocolatey Windows Package Manager and then installing Git, when tried to run the command line "ROS Last Known Good (LKG) Build Installation", an error prompted saying;

Chocolatey v0.10.15 Directory 'c:\opt\chocolatey\lib' does not exist. Added ros-win - https://roswin.azurewebsites.net/api/v2 (Priority 1)

I assume the Chocolatey installation wasn't successful, but how can I fix this so I can continue the installation process for ROS?

I'd appreciate it if anyone can help me out. Thank you.

----EDIT (5/12/2020):

I have double-checked and made sure that I have installed the latest version of both Chocolatey & Git, and I'm confident now that I have followed every step correctly. When I tried to run the next line of command to continue the installation ( the command line for "ROS Last Known Good (LKG) Build Installation"), I get the same error again. At this point, I really don't know what is going wrong. Shouldn't there be a folder called "lib" in the "opt" folder already when I downloaded these things?

Can someone please advise?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-01-26 12:34:57 -0600

ShunSu gravatar image

use this command

choco upgrade chocolatey

before

choco upgrade ros-noetic-desktop_full -y --execution-timeout=0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-05-10 21:08:02 -0600

Seen: 650 times

Last updated: May 12 '20