roscore problem of lunar in ubuntu(16.04) of windows 10 subsystem

asked 2018-04-10 10:07:58 -0500

S_luminary gravatar image

I install lunar in ubuntu(16.04) of windows 10 subsystem according to

step by step.

However, when I


Result is :

... logging to /home/sgl/.ros/log/fa6cf3ea-3ccf-11e8-a218-f48e389f9e57/roslaunch-sgl-laptop-10244.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

*RLException: Unable to contact my own server at [http://ip6-localhost:5662/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

        ping ip6-localhost

For more tips, please see*

The traceback for the exception was written to the log file

And I ping the localhost, it's ok. I also check my etc/hosts, it is it doesn't work

Then, I try to change localhost into my computer account, I still get wrong.

Pls some big man can tell me what to do. Thx!!!!

edit retag flag offensive close merge delete


This is a network configuration issue on the Ubuntu side of WSL. This is not really a ROS problem, but a system configuration one. It looks like WSL is returning the IPv6 hostname first, which doesn't seem to work.

Can you ping ip6-localhost?

gvdhoorn gravatar image gvdhoorn  ( 2018-04-10 14:15:45 -0500 )edit

I ping ip6-localhost, localhost, also my computer account “sgl-laptop”, ping results are same as:

--- ip6-localhost ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6004ms
rtt min/avg/max/mdev = 0.107/0.134/0.176/0.020 ms

but I still get the same problem

S_luminary gravatar image S_luminary  ( 2018-04-10 21:43:01 -0500 )edit

Just to see what happens, can you try the following and report the results? In a bash terminal:

export ROS_IP=

If that does work, it would point to an issue with DNS resolution. The ip6-localhost is most likely the IPv6 localhost (::1) and I'm not sure IPv6 ..

gvdhoorn gravatar image gvdhoorn  ( 2018-04-11 01:56:52 -0500 )edit

.. is supported well enough for ROS to use it under WSL.

BTW: note that WSL is not a supported platform for ROS, so there might be issues like this that prevent you from using it there.

gvdhoorn gravatar image gvdhoorn  ( 2018-04-11 01:57:05 -0500 )edit

still the same problem,sad!!!

S_luminary gravatar image S_luminary  ( 2018-04-11 10:24:51 -0500 )edit

So with ROS_IP set roscore still prints:

RLException: Unable to contact my own server at [http://ip6-localhost:5662/].

that would be strange.

gvdhoorn gravatar image gvdhoorn  ( 2018-04-11 12:23:44 -0500 )edit