Ask Your Question
0

ERROR: Rosdep cannot find all required resources to answer your query

asked 2020-04-07 21:10:19 -0500

Dean gravatar image

updated 2020-04-07 21:20:09 -0500

I am learning ROS seriously from 2 weeks ago,step by step according to the wiki ROS Tutorials: --installed successfully ROS according to it,with melodic ,with ubuntu 18.04; --just finished successfully "1.Core ROS Tutorials>>1.1 Beginner Level",everythings are OK; Note:During this process, I met some questions, some solved by searching in google.com,baidu.com, etc;others solved by you kind guys,thanks again here.This Q&A is too strong, there are so many kind people to help each other, I believe i will make some great Robots powered by ROS in the future. --begin to study "1.2 Intermediate Level" from today.

Ok,now let me launch my new question: When doing this step: http://wiki.ros.org/ROS/Tutorials/rosdep

$ rosdep install turtlesim

I see:

Command 'rosdep' not found, but can be installed with:

sudo apt install python-rosdep2

Can I do so?

I dare not do so, because I remembered the answers in my other question's several days ago: python-roswtf is the wrong package(it is indeedly true)

and advices: Don’t mix the streams,(see it in http://wiki.ros.org/UpstreamPackages)

I decide to solve it by myself firstly, and I did these things as follows:

$ sudo apt install ros-melodic-rosdep2

E: couldn't location the sw package ros-melodic-rosdep2

$ sudo easy_install -U rosdep rospkg

sudo: easy_install:didn't find this command

$sudo apt-get install python-rosdep

E: couldn't download http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 2600:3404:200:237::2 80] E: There are some sw packages couldn't be downloaded, try apt-get update or add --fix-missing ?

Note:I dare not do so. Considering mybe web connection question, I tried sudo apt-get install python-rosdep for more four times, but failed either.

$ sudo apt-get install python-rosdep2 [sudo] dean pwd: ...... Belows sw packages are auto-installed and not need any more: gcc-4.8-base gdal-data gir1.2-harfbuzz-0.0 google-mock googletest ibverbs-providers icu-devtools libaec0 libapr1-dev libaprutil1-dev libarmadillo8 libarpack2 libasan0 libassuan-dev libavcodec-dev libavformat-dev libavresample-dev libavutil-dev libblas3 libboost-all-dev libboost-atomic-dev libboost-atomic1.65-dev libboost-atomic1.65.1 libboost-chrono-dev libboost-chrono1.65-dev libboost-chrono1.65.1 libboost-container-dev libboost-container1.65-dev libboost-container1.65.1 libboost-context-dev libboost-context1.65-dev libboost-context1.65.1 libboost-coroutine-dev libboost-coroutine1.65-dev libboost-coroutine1.65.1 libboost-date-time-dev libboost-date-time1.65-dev libboost-dev libboost-exception-dev libboost-exception1.65-dev libboost-fiber-dev libboost-fiber1.65-dev libboost-fiber1.65.1 libboost-filesystem-dev libboost-filesystem1.65-dev libboost-graph-dev libboost-graph-parallel-dev libboost-graph-parallel1.65-dev libboost-graph-parallel1.65.1 libboost-graph1.65-dev libboost-graph1.65.1 libboost-iostreams-dev libboost-iostreams1.65-dev libboost-locale-dev libboost-locale1.65-dev libboost-log-dev libboost-log1.65-dev libboost-log1.65.1 libboost-math-dev libboost-math1.65-dev libboost-math1.65.1 libboost-mpi-dev libboost-mpi-python-dev libboost-mpi-python1.65-dev libboost-mpi-python1.65.1 libboost-mpi1.65-dev libboost-mpi1.65.1 libboost-numpy-dev libboost-numpy1.65-dev libboost-numpy1.65.1 libboost-program-options-dev libboost-program-options1.65-dev libboost-program-options1.65.1 libboost-python-dev libboost-python1.65-dev libboost-python1.65.1 libboost-random-dev libboost-random1.65-dev libboost-random1.65.1 libboost-regex-dev libboost-regex1.65-dev libboost-regex1.65.1 libboost-serialization-dev libboost-serialization1.65-dev libboost-serialization1.65.1 libboost-signals-dev libboost-signals1.65-dev libboost-signals1.65.1 libboost-stacktrace-dev libboost-stacktrace1.65-dev libboost-stacktrace1.65.1 libboost-system-dev libboost-system1.65-dev libboost-test-dev libboost-test1.65-dev libboost-test1.65.1 libboost-thread-dev libboost-thread1.65-dev libboost-timer-dev libboost-timer1.65-dev libboost-timer1.65.1 libboost-tools-dev libboost-type-erasure-dev libboost-type-erasure1.65-dev libboost-type-erasure1.65.1 libboost-wave-dev libboost-wave1.65-dev libboost-wave1 ... (more)

edit retag flag offensive close merge delete

Comments

$ rosdep update

ERROR: error loading sources list: <urlopen 111]="" <urlopen="" [errno="" connection="" error="" refused=""> (https://raw.githubusercontent.com/ros...></urlopen>

Dean gravatar image Dean  ( 2020-04-07 21:51:34 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-04-07 21:49:50 -0500

updated 2020-04-07 21:50:08 -0500

It looks like you installed rosdep2, which I believe is either deprecated or forked for ROS2. I have the following apt packages installed on my computer:

python-rosdep/bionic,bionic,now 0.18.0-1 all [installed]
rosdep package manager abstraction tool for ROS

python-rosdep-modules/bionic,bionic,now 0.18.0-1 all [installed,automatic]
rosdep package manager abstraction tool for ROS

python-rosdep2/bionic,bionic 0.11.8-1 all
rosdep package manager abstraction tool for Robot OS (Python 2)
edit flag offensive delete link more

Comments

In fact, I don't understand the relations ,the differences between ROS-melodic and ROS2, only know ROS2 is more better.Heard from you : forked for ROS2. I am more confused in the two version's differences, and how to do with ROS2, after all, i didn't see anything about ROS2 in wiki ROS Tutorials, I only have some websites about ROS2 like these:

https://index.ros.org/doc/ros2/

Dean gravatar image Dean  ( 2020-04-07 22:03:06 -0500 )edit

Now, i met more questions:

$ roscd turtlesim

Command 'roscd' not found, did you mean:

command 'rosco' from deb python-rosinstall

Try: sudo apt install <deb name="">

$ roscore

Command 'roscore' not found, but can be installed with:

sudo apt install python-roslaunch

$ echo "source /opt/ros/melodic/setup.bash" >> ~/.bashrc $ source ~/.bashrc $ roscore

Command 'roscore' not found, but can be installed with:

sudo apt install python-roslaunch

$ source /opt/ros/melodic/setup.bash $ roscore

Command 'roscore' not found, but can be installed with:

sudo apt install python-roslaunch

As if i came back the beginning of everything, how to solve it? I can't play roscore again.

I met the same question before, see my first question:

https://answers.ros.org/question/3479...

Dean gravatar image Dean  ( 2020-04-07 22:53:48 -0500 )edit

$ sudo apt install --reinstall ros-melodic-roslaunch

This is the answer for my first question in this website, and i did it again, and roscore did work again.

But:

$ roscd turtlesim

Command 'roscd' not found, did you mean:

command 'rosco' from deb python-rosinstall

Try: sudo apt install <deb name="">

Roscd doesn't work yet.

Dean gravatar image Dean  ( 2020-04-07 23:00:34 -0500 )edit

When sudo apt-get install python-rosdep2, it uninstalled so many packages, i don't know why?

I don't konw whether this uninstallation leads to these new questions?

Such as: Command 'roscd' not found which not sloved till now,

and Command 'roscore' not found which sloved again even though.

Dean gravatar image Dean  ( 2020-04-07 23:10:16 -0500 )edit

Rosrun is disappeared too, like as:

$ rosrun beginner_tutorials talker.py

Command 'rosrun' not found, but can be installed with:

sudo apt install rosbash

But i ever finished it successfully yesterday.

What is wrong with all of things?

Dean gravatar image Dean  ( 2020-04-08 02:27:52 -0500 )edit

Look forward to your help,thank you!Wait on line.

Dean gravatar image Dean  ( 2020-04-08 02:29:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-04-07 21:10:19 -0500

Seen: 1,185 times

Last updated: Apr 07 '20