Ask Your Question

IOError: [Errno 13] Permission denied: 'params.yaml'

asked 2020-04-05 22:30:44 -0600

Dean gravatar image

updated 2020-04-06 02:49:00 -0600

gvdhoorn gravatar image

$ rosparam dump params.yaml

Traceback (most recent call last):
  File "/opt/ros/melodic/bin/rosparam", line 35, in <module>
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rosparam/", line 620, in yamlmain
    _rosparam_cmd_get_dump(command, argv)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rosparam/", line 444, in _rosparam_cmd_get_dump
    dump_params(arg, script_resolve_name(NAME, ns), verbose=options.verbose)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rosparam/", line 299, in dump_params
    f = open(filename, 'w')
IOError: [Errno 13] Permission denied: 'params.yaml'

Where is params.yaml? Need I create it before this command?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-04-05 23:49:51 -0600

Dean gravatar image

updated 2020-04-06 02:49:42 -0600

gvdhoorn gravatar image

Replace <distro> with the name of your ROS distribution (e.g. indigo, jade, kinetic, lunar...):

$ sudo apt-get install ros-<distro>-rqt ros-<distro>-rqt-common-plugins ros-<distro>-turtlesim

NOTE: you may have already built rqt and turtlesim for one of the previous tutorials. If you are not sure, installing them again will not hurt anything.

edit flag offensive delete link more


Is this an answer? Or an update?

It's unclear to me how installing rqt solves a permission problem.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-06 02:49:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2020-04-05 22:30:44 -0600

Seen: 167 times

Last updated: Apr 06 '20