Ask Your Question
0

Error launching Rplidar node

asked 2020-04-03 06:58:34 -0500

Alessandro Melino gravatar image

updated 2020-04-21 03:42:28 -0500

Hello everyone.

I am using a RPLidar A1M8 to generate obstacles using move_base and costmap_2d. The problem arrives when I launch rplidar node with the whole system .launch; you can see the include where I call the .launch file of rplidar:

  <include file="$(find rplidar_ros)/launch/rplidar.launch" />

The next error appears on terminal when I launch it:

 [ERROR] [1585914589.956502460]: Error, operation time out. RESULT_OPERATION_TIMEOUT! 
[rplidarNode-20] process has died [pid 14017, exit code 255, cmd /home/sara/catkin_ws/devel/lib/rplidar_ros/rplidarNode __name:=rplidarNode __log:=/home/sara/.ros/log/35a653a0-75a1-11ea-83b0-701ce7079383/rplidarNode-20.log].
log file: /home/sara/.ros/log/35a653a0-75a1-11ea-83b0-701ce7079383/rplidarNode-20*.log

I tried to read the .log file, but it doesn't appear on that directory.

By the way, if I launch first the whole system in one terminal and then I launch the rplidar node using other terminal, it works and I can see rplidar working and generating obstacles on rviz.

What can I do to solve the problem and launch rplidar whit the system together?

Thanks in advance.

Best regrets. Alessandro

EDIT: I solve the problem not launching other node that uses the same usb port of the rplidar, so it was my fault. Thank you.

edit retag flag offensive close merge delete

Comments

1

Please post your last edit as an answer instead.

And then accept your own answer.

This would convey the fact that your issue was resolved much better than closing a question.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-21 05:54:10 -0500 )edit

Done. Thanks, i am still adapting to ROS Answers.

Alessandro Melino gravatar image Alessandro Melino  ( 2020-04-21 05:56:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-04-21 05:55:42 -0500

Alessandro Melino gravatar image

I solve the problem not launching other node that uses the same usb port of the rplidar, so it was my fault. Thank you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-03 06:58:34 -0500

Seen: 185 times

Last updated: Apr 21 '20