Ask Your Question
0

openni_camera glibc error

asked 2011-06-30 00:55:31 -0500

qdocehf gravatar image

updated 2016-10-24 08:33:45 -0500

ngrennan gravatar image

I am using ROS on Ubuntu 10.04, and the command "roslaunch openni_camera openni_node.launch" has suddenly started to give me an error. Is there a way to fix this?

robot@peoplebot2:~$ roslaunch openni_camera openni_node.launch
... logging to /home/robot/.ros/log/7354f21c-a317-11e0-8aa3-a088b4402bbc/roslaunch-peoplebot2-1665.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://peoplebot2:50030/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [1679]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 7354f21c-a317-11e0-8aa3-a088b4402bbc
process[rosout-1]: started with pid [1692]
started core service [/rosout]
process[openni_node1-2]: started with pid [1695]
process[kinect_base_link-3]: started with pid [1696]
process[kinect_base_link1-4]: started with pid [1697]
process[kinect_base_link2-5]: started with pid [1698]
process[kinect_base_link3-6]: started with pid [1699]
/opt/ros/diamondback/stacks/openni_kinect/openni_camera/bin/openni_node: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.12' not found (required by /usr/lib/libOpenNI.so)
[openni_node1-2] process has died [pid 1695, exit code 1].
log files: /home/robot/.ros/log/7354f21c-a317-11e0-8aa3-a088b4402bbc/openni_node1-2*.log

I have followed dornhege's advice from the comments in the answer by fergs. When I only use the command "roslaunch openni_camera openni_node.launch", it runs correctly. However, when I try to use other packages that require the openni_camera, such as rviz or openni_tracker, this new error occurs. Does anyone have an idea for fixing it?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-02 12:20:32 -0500

kwc gravatar image

no activity > 1 month, closing

edit flag offensive delete link more
2

answered 2011-07-06 04:36:30 -0500

fergs gravatar image

Lucid (10.04) uses GLIBC 2.11, so lucid packages should not be linked against 2.12. Are you sure that you selected the right repository when you did step 1.2 of installation? I would guess that you might have typed "maverick" instead of "lucid" thus installing packages that use GLIBC 2.12.

edit flag offensive delete link more

Comments

Yes, I definitely used the lucid installation. I even tried uninstalling and reinstalling it, so I don't think that could be the problem.
qdocehf gravatar image qdocehf  ( 2011-07-06 05:14:05 -0500 )edit
To verify, what does: apt-cache policy ros-diamondback-openni-kinect give you?
dornhege gravatar image dornhege  ( 2011-07-06 07:10:28 -0500 )edit
ros-diamondback-openni-kinect: Installed: 0.2.1-s1306611764~lucid Candidate: 0.2.1-s1306611764~lucid Version table: *** 0.2.1-s1306611764~lucid 0 500 http://packages.ros.org/ros/ubuntu/ lucid/main Packages 100 /var/lib/dpkg/status
qdocehf gravatar image qdocehf  ( 2011-07-06 07:24:33 -0500 )edit
Can your try running apt-get update, apt-get upgrade and eventually apt-get --reinstall install openni-dev. That should get you up to date to the current lucid packages.
dornhege gravatar image dornhege  ( 2011-07-07 01:25:58 -0500 )edit
Do you have any ideas for fixing this new error? I have edited my question to include the new problem.
qdocehf gravatar image qdocehf  ( 2011-07-07 06:09:05 -0500 )edit
@qdocehf I would suggest removing the second question and making a separate posting for it.
Asomerville gravatar image Asomerville  ( 2011-07-14 09:03:13 -0500 )edit
0

answered 2011-07-06 04:37:18 -0500

Bemfica gravatar image

Post the return of this command:

sudo find / -print0 | grep -FzZ "/lib/libc.so"

you'll get all versions of "libc.so". Then you could make a soft link.

edit flag offensive delete link more

Comments

/lib/libc.so.6/usr/lib/libc.so
qdocehf gravatar image qdocehf  ( 2011-07-06 05:11:01 -0500 )edit
What is a soft link?
qdocehf gravatar image qdocehf  ( 2011-07-06 05:12:59 -0500 )edit
It's just a "shortcut". But now you know that the library probably isn't the problem.
Bemfica gravatar image Bemfica  ( 2011-07-06 07:43:17 -0500 )edit
Do you have any ideas for what the problem could be?
qdocehf gravatar image qdocehf  ( 2011-07-06 07:52:21 -0500 )edit
The error message displays this library: /lib/tls/i686/cmov/libc.so.6. Do you know where this comes from? It seems to be different from the standard installed one.
dornhege gravatar image dornhege  ( 2011-07-06 09:10:13 -0500 )edit
I do not know where it came from.
qdocehf gravatar image qdocehf  ( 2011-07-07 01:01:00 -0500 )edit
I checked my system and its pointing to the 2.11 version, which is OK. I'd still blame your ROS install.
dornhege gravatar image dornhege  ( 2011-07-07 01:14:36 -0500 )edit
This comment is here for the 5 comments bug...
dornhege gravatar image dornhege  ( 2011-07-07 01:15:41 -0500 )edit
0

answered 2011-07-04 23:30:55 -0500

I guess your libc version is not the one openni was compiled against. Try recompiling/linking the openni_camera package and/or google for libc.so.6: version GLIBC_2.12 not found

edit flag offensive delete link more

Comments

I cannot find anything online, and reinstalling it did not help. Strangely, it worked for about a day when I initially installed it, but now it obviously is not. Do you have any other ideas?
qdocehf gravatar image qdocehf  ( 2011-07-05 01:02:46 -0500 )edit
Did you install from source or packages?
dornhege gravatar image dornhege  ( 2011-07-06 03:53:28 -0500 )edit
I installed from packages.
qdocehf gravatar image qdocehf  ( 2011-07-06 04:01:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-30 00:55:31 -0500

Seen: 996 times

Last updated: Sep 02 '11