Ask Your Question
1

Resource_retriever package doesn't build in ROS2 Windows

asked 2020-03-23 10:14:52 -0500

drkleppe gravatar image

Hello, I'm trying to build ROS2 Eloquent for Windows using the guide: https://index.ros.org/doc/ros2/Instal...

The problem occurs when I build the "resource_retriever" package, when the whole build fails. In order to debug slightly I ran

colcon build --merge-install --packages-select resource_retriever --event-handler console_cohesion+

Resulting in

Starting >>> resource_retriever
--- output: resource_retriever
[6.968s] -- Found ament_cmake_ros: 0.8.0 (C:/dev/ros2_eloquent/install/share/ament_cmake_ros/cmake)
[7.375s] -- Using PYTHON_EXECUTABLE: C:/Python37/python.exe
[8.640s] -- Found ament_index_cpp: 0.7.2 (C:/dev/ros2_eloquent/install/share/ament_index_cpp/cmake)
[8.703s] -- Found libcurl_vendor: 2.2.1 (C:/dev/ros2_eloquent/install/share/libcurl_vendor/cmake)
[8.796s] -- library: C:/dev/ros2_eloquent/install/opt/libcurl_vendor/bin/libcurl.dll
[9.234s] -- Configuring done
[9.828s] -- Generating done
[9.875s] -- Build files have been written to: C:/dev/ros2_eloquent/build/resource_retriever
[10.234s] Microsoft (R) Build Engine version 16.5.0+d4cbfca49 for .NET Framework
[10.234s] Copyright (C) Microsoft Corporation. All rights reserved.
[10.234s]
[11.125s] C:\dev\ros2_eloquent\install\opt\libcurl_vendor\bin\libcurl.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x310     [C:\dev\ros2_eloquent\build\resource_retriever\resource_retriever.vcxproj]
---
Failed   <<< resource_retriever [ Exited with code 1 ]

Summary: 0 packages finished [12.6s]
  1 package failed: resource_retriever

No other errors come up until this point, and I have no idea how to solve it

edit retag flag offensive close merge delete

Comments

I'm also facing the same error. Please let us know if you're able to solve this issue. Thanks

webvenky gravatar image webvenky  ( 2020-04-08 22:02:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-04-09 11:57:45 -0500

sloretz gravatar image

updated 2020-04-13 10:56:08 -0500

This bug was fixed in https://github.com/ros/resource_retri... . It has not yet been backported to ROS Eloquent, but I would expect it to be in the next ROS Eloquent sync.

Edit: It has been backported to Eloquent, and is fixed as of version 2.2.2

edit flag offensive delete link more

Comments

Making the changes made as in https://github.com/ros/resource_retri... does the trick. Thank you.

webvenky gravatar image webvenky  ( 2020-04-12 08:07:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-03-23 10:13:35 -0500

Seen: 74 times

Last updated: Apr 13