ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Ros1_bridge can't mapping my msgs..... HELP

asked 2020-03-19 10:22:51 -0500

Freesun gravatar image

I installed Ros1_bridge by apt install ros-dashing-ros1_birdge. and refered to

i make 'my_mapping_rules.yaml'

  ros1_package_name: 'tut_msgs'
  ros1_message_name: 'Num'
  ros2_package_name: 'tut_msgs'
  ros2_message_name: 'Num'

    data: 'data' 

#/home/freesun/ros2_ws/src/tut_msgs/msg/Num.msg                  ros2_workspace
#/home/freesun/catkin_ws/src/tut_msgs/msg/Num.msg                ros1_workspace

and placed in /home/freesun/ros2_ws/src/tut_msgs Finally i modifed msg's CMakeList.txt and package.xml.

But it doesn't working. CANT MAPPING MY MESSAGES!!!!!!!

what's the problem???


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-03-19 10:47:34 -0500

marguedas gravatar image

installed Ros1_bridge by apt install ros-dashing-ros1_birdge

This is the reason. The bridge provided in ros-dashing-ros1-bridge has no knowledge of your messages. You need to build a custom bridge from source.

If you follow the steps of the document you link to it will guide you through how to setup workspaces, build your messages and how to build a bridge capable of bridging your messages

edit flag offensive delete link more


oh! i got it! i'll do that!! thx :)

Freesun gravatar image Freesun  ( 2020-03-19 12:06:02 -0500 )edit

umm.... i faced another problem! when i run all nodes. ros1_bridge suddenly shut down. here is error message :

   $ ros2 run ros1_bridge dynamic_bridge 
created 2to1 bridge for topic '/rosout' with ROS 2 type 'rcl_interfaces/msg/Log' and ROS 1 type 'rosgraph_msgs/Log'
created 1to2 bridge for topic '/my_topic' with ROS 1 type 'tut_msgs/Num' and ROS 2 type 'tut_msgs/msg/Num'
[INFO] [ros_bridge]: Passing message from ROS 1 tut_msgs/Num to ROS 2 tut_msgs/msg/Num (showing msg only once per type)
realloc(): invalid pointer
Freesun gravatar image Freesun  ( 2020-03-19 12:28:54 -0500 )edit

this is unfortunate

Are you using CycloneDDS by any chance ? Did you try looking for a similar issue on the ros1_bridge repository ? This looks pretty similar to your issue

marguedas gravatar image marguedas  ( 2020-03-19 13:02:03 -0500 )edit

okay... i'll search more issues! thank u ;)

Freesun gravatar image Freesun  ( 2020-03-19 13:09:12 -0500 )edit

Hello!! I solved it when i install cyclone dds!!

Freesun gravatar image Freesun  ( 2020-03-20 06:35:29 -0500 )edit

glad you can now bridge your messages. As your problem is solved, could you please close the question or, if it answered your original question, accept the proposed answer by clicking the checkmark on the left. This will allow to remove your question from the unanswered list

marguedas gravatar image marguedas  ( 2020-03-20 08:45:50 -0500 )edit

Question Tools

1 follower


Asked: 2020-03-19 10:22:51 -0500

Seen: 591 times

Last updated: Mar 19 '20