Ask Your Question
0

Gazebo/Boost 'Host not found' error

asked 2012-05-22 02:32:19 -0500

brunopop gravatar image

Hi,

I installed Gazebo 1.0.1 (from May 15, 2012) with all required dependencies on Ubuntu 11.10 (Oneiric, 64-bit).

I get the following error when launching gzserver:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >' what(): Host not found (authoritative) Aborted

The same error was reported on ArchLinux but didn't find a clear answer (https://aur.archlinux.org/packages.php?ID=20839)

I changed the environment variable GAZEBO_MASTER_URI to 'http://127.0.0.1:12345' as advised and could successfully launch gazebo but the Plugin_CgProgramManager.so file was reported missing. I then quit gazebo and try to install the ogre-plugins-cgprogrammanager package, which contains the missing plugin file, after installing the nvidia-cg-toolkit package. It failed as the only available version of ogre-plugins-cgprogrammanager (1.6.4) is older than libogre-1.7.3 that is already installed.

Since then, I tried to launch gzserver or gazebo again and I get the error mentioned above, again, whether GAZEBO_MASTER_URI is set to the default 'http://localhost:11345' or to the recommended 'http://127.0.0.1:12345'.

I have two problems:

  1. The 'Host not found error' when using Boost (1.46.1)
  2. The missing Plugin_CgProgramManager.so in /usr/lib/OGRE/.

There is one possible solution I haven't investigated yet: installing Gazebo from the source files posted on ArchLinux and that are more up-to-date than the Debian binary on the Gazebo website (May 18 v. May 15).

If anyone has faced the same problem, thank you for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-22 08:48:22 -0500

brunopop gravatar image

Everything was solved after updating the whole system with apt-get and installing missing packages from the PPA of Ogre as described in this other thread:

http://answers.ros.org/question/32346/how-do-i-fix-this-error-message-with-gazeboogre/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-05-22 02:32:19 -0500

Seen: 698 times

Last updated: May 22 '12