Ask Your Question
0

I wish to move a UR5 Robot with Rviz and ur-robot-driver

asked 2020-02-27 14:38:48 -0500

brodwix gravatar image

updated 2020-02-28 13:51:45 -0500

Hello, i followed the tutorial on "Setting up a UR robot for ur_robot_driver"

for this, i generated a catkin_ws containing fmauch-universal-robot package and ur-robot-driver

https://github.com/UniversalRobots/Un...

i didn't have any problems moving the robot using rqt_joint_trajectory_controller

$rosrun rqt_joint_trajectory_controller rqt_joint_trajectory_controller

I wish to move the robot using Rviz, so after communicating my laptop with the robot, i put these commands on terminal

$roscore
$roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch limited:=true
$roslaunch ur5_moveit_config moveit_rviz.launch config:=true

everything seemed to be ok, the planning apparently worked, but when i hit "execute", the moveit terminal showed this message:

ABORTED: Solution found but controller failed during execution

also the ur5_moveit_planning_execution terminal window showed me this:

[ERROR] [1582833158.929619051]: Unable to identify any set of controllers that can actuate the specified joints: [ elbow_joint shoulder_lift_joint shoulder_pan_joint wrist_1_joint wrist_2_joint wrist_3_joint ]
[ERROR] [1582833158.929645911]: Known controllers and their joints:

i think this has something to do with the action server on

/scaled_pos_traj_controller/follow_joint_trajectory

my question is, how can i use this action server to work with moveit just like rqt_joint_trajectory_controller?

Thanks a lot for your help!!

edit retag flag offensive close merge delete

Comments

please how did you run without any error since i am trying the same but lot of lot of error for past 1 month iam trying no progress

nullspace gravatar image nullspace  ( 2020-11-06 01:58:49 -0500 )edit

It might be better if you posted your own question with your own description and error @nullspace.

@brodwix: Does your URDF set a prefix for the robot which changes the joint names?

fvd gravatar image fvd  ( 2020-11-06 02:53:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-21 03:21:39 -0500

Jan_ gravatar image

I hope, you solved your problem. I had the same problem and figure it out, so everybody with the same problem: here is my solution.

The file

your_catkin_ws/sc/fmauch_universal_robot/"your_ur"_moveit_config/config/controllers.yaml

has to look as follow:

    controller_list:
  - name: ""
    action_ns: /scaled_pos_joint_traj_controller/follow_joint_trajectory
    type: FollowJointTrajectory
    joints:
      - shoulder_pan_joint
      - shoulder_lift_joint
      - elbow_joint
      - wrist_1_joint
      - wrist_2_joint
      - wrist_3_joint

You have to change "your_ur" with your robot (in this case UR5)

Hope that helps other people starting with ros!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2020-02-27 14:38:48 -0500

Seen: 398 times

Last updated: Feb 28 '20