Ask Your Question
0

rviz symbol lookup error

asked 2017-07-25 11:04:17 -0500

Yaser gravatar image

updated 2017-07-25 12:06:15 -0500

allenh1 gravatar image

I am trying to run rviz on kinetic. while running I get the following error.

$ rosrun rviz rviz
/opt/ros/kinetic/lib/rviz/rviz: symbol lookup error: /opt/ros/kinetic/lib/librviz.so: undefined symbol: _ZNK9QTreeView16viewportSizeHintEv

I tried dist-upgrade and remaking my catkin workspace but neither solved the problem. What might be the source of this issue?

edit retag flag offensive close merge delete

Comments

It's really difficult to say without more information. What operating system/version are you running?

allenh1 gravatar image allenh1  ( 2017-07-25 12:06:51 -0500 )edit

I'm using Ubuntu 16.04 LTS and ROS kinetic.

Yaser gravatar image Yaser  ( 2017-07-27 09:06:22 -0500 )edit

What are you attempting to do with rviz?

allenh1 gravatar image allenh1  ( 2017-07-30 17:09:13 -0500 )edit

I am trying to get Phantom Omni device work with ROS. I followed the instructions stated here: http://fsuarez6.github.io/projects/ge... . However, when the launch node tries to start, the above-mentioned error appears.

Yaser gravatar image Yaser  ( 2017-08-01 06:46:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-10-17 11:27:17 -0500

john.j.oneill gravatar image

updated 2017-10-18 05:45:28 -0500

I had the same problem, using Ubuntu 16.04 LTS and ROS kinetic, and I had also recently installed the Phantom Omni's geomagic touch device driver. It turns out that the geomagic touch device driver adds its own Qt5 dynamic library files in /opt/geomagic_touch_device_driver/lib and then adds that to the LD_LIBRARY_PATH. These are then used by rviz (among other Qt apps) instead of the correct ones. To find out if this applies to you as well, run:

echo $LD_LIBRARY_PATH

And if you see /opt/geomagic_touch_device_driver/lib included, that is the culprit. I personally didn't need any of the Qt functionality of the Phantom Omni, so I just stopped it from adding that directory to the LD_LIBRARY_PATH which can be done by editing the following file:

sudo nano /etc/profile.d/geomagic.sh

to remove the export LD_LIBRARY_PATH line, and possibly also the QT line. You will then have to reboot for these changes to take effect. This will possibly break your Phantom Omni if it needs the other non-Qt files in that directory. I just linked them to my /usr/lib directory, and now I can run the Omni code and rviz.

edit flag offensive delete link more

Comments

how to use a Omni connect a real robot like ur5/Sawyer

JiaoYL gravatar image JiaoYL  ( 2020-01-06 03:15:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-07-25 11:04:17 -0500

Seen: 1,305 times

Last updated: Oct 18 '17