Ask Your Question
0

ROS time starts at 90

asked 2020-01-13 03:34:01 -0600

davidem gravatar image

I am working with ROS Melodic on Ubuntu 18.04, using Gazebo as virtualizer and a Turtlebot.
So far, with every simulation I ran, I used the so-called turtlebot_house.world that came with installing the ROBOTIS Turtlebot3 simulations package.
When I use that world, ROS time correctely starts at 0.00 secs.
Recently, I defined my own world using the Gazebo world editor tool as described in this video. When I launch a simulation in my world, ROS time starts at approx 90.00 secs: I can see this in the stdout shell and also getting the time inside my scripts.

I have no clue in what's wrong nor what to do to provide further details. The same issue also happens across PCs.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-13 03:44:36 -0600

davidem gravatar image

Found the solution myself: gotta say it's definetly awkward, but for some reason my exported world had these four parameters:

<sim_time>92 36000000</sim_time>
<real_time>92 561712388</real_time>
<wall_time>1578849264 106447901</wall_time>
<iterations>92036</iterations>

I just commented them out and the time correctely starts at 0.00

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-01-13 03:34:01 -0600

Seen: 10 times

Last updated: Jan 13