ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS related commands are not executed in terminal

asked 2019-12-28 13:33:27 -0500

Tahir M. gravatar image

updated 2019-12-28 15:18:52 -0500

Hello, I am not able to run ros commands in terminal. When I enter any ros related command in terminal its not executed. I don't know what is the problem and can not find any solution on internet.image description

Edit: 1 roscore is not running in the screenshot below, so I expect there should be an error which says for masters not running or something similar. Also in a same way for example if I run roscore than there are few checks like for log file and a few messages like master is running so in that case nothing happens as well that does the something like screenshot below.

edit retag flag offensive close merge delete


There is nothing in the terminal that suggests it is not being executed (it has not generated any errors), and has not returned the prompt so is still executing.

You need to be more specific for people to be able to provide help. Are you expecting something else to happen that hasn't ? Have you run anything else in any other terminals ?

I suspect that you have already run roscore in another terminal, or you would have got an error.

nickw gravatar image nickw  ( 2019-12-28 14:09:53 -0500 )edit

@nickw please look the edit: 1 hope it clarifies now.

Tahir M. gravatar image Tahir M.  ( 2019-12-28 15:19:52 -0500 )edit

It is still hard to say - it is not clear what you are trying to do, and what you expect to be happening.

logout and back in to make sure nothing is running in the background.

I'm assuming that you have just installed ros and are trying to work through some examples - what other commands/tutorials have you tried, and what results did you get ?

node tutorial is a good place to start to get an idea of what needs to be running, and what you should use to check if things are running correctly (like rosnode list), followed by the topic example that is linked to at the end of it.

Try that and see if it is clearer what is and isnt working.

nickw gravatar image nickw  ( 2019-12-28 16:16:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-12-28 16:45:03 -0500

Tahir M. gravatar image

Well sorry my fault. Just got found the mistake. I actually I am running ros on multiple machines. So when I do some ros related stuff and the server PC is turned off whose ip is set as ros_master_uri, so after turning on the another PC or removing the settings from .bashrc I can run everything very smoothly. @nickw thanks man for your reply and time.

edit flag offensive delete link more

Question Tools



Asked: 2019-12-28 13:33:27 -0500

Seen: 388 times

Last updated: Dec 28 '19