Ask Your Question
0

Vehicle does not move following by multiple waypoint files

asked 2019-12-12 21:11:32 -0600

tiensu gravatar image

Hi all!

I have worked with Autoware and LGSVL Simulation. I created some waypoint files and used waypoint_loader node to read them (waypoint_loader node allows load multiple waypoint files). But the car (in LGSVL Simulation) only move following by the first waypoint file.

Do you know how to make the car move following multiple waypoint files in order?

Thank you very much!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-12-16 16:01:46 -0600

Josh Whitley gravatar image

waypoint_loader does not currently handle multiple waypoint files. The simplest way to solve this problem is by combining the waypoint files into one. You'll have to remove the headers from all files but the first but this should be pretty easy. Then you can just concatenate them.

edit flag offensive delete link more

Comments

I think it can. I loaded multiple waypoint files in waypoint_loader node. When the first file is played completely, I click "app" on waypoint_loader node again, the next file is played continuously. I don't know why?

tiensu gravatar imagetiensu ( 2019-12-16 19:55:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-12-12 21:11:32 -0600

Seen: 40 times

Last updated: Dec 16 '19