Ask Your Question
0

pixhawk connection JETSON TX2

asked 2019-12-04 01:01:09 -0600

Hello Everyone. I’m new in ROS. I run roslaunch mavros px4.launch fcu_url:="/dev/ttyTHS1:921600" gcs_url:="udp://@10.42.0.85" and I get this:

  • [ INFO] [1575371919.146839830]: Plugin rc_io initialized
  • [ INFO] [1575371919.147169913]: Plugin safety_area blacklisted
  • [ INFO] [1575371919.147721256]: Plugin setpoint_accel loaded
  • [ INFO] [1575371919.155037956]: Plugin setpoint_accel initialized
  • [ INFO] [1575371919.156070857]: Plugin setpoint_attitude loaded
  • [ INFO] [1575371919.180280403]: Plugin setpoint_attitude initialized
  • [ INFO] [1575371919.180962551]: Plugin setpoint_position loaded
  • [ INFO] [1575371919.223178064]: Plugin setpoint_position initialized
  • [ INFO] [1575371919.223720608]: Plugin setpoint_raw loaded
  • [ INFO] [1575371919.250321304]: Plugin setpoint_raw initialized
  • [ INFO] [1575371919.251363420]: Plugin setpoint_trajectory loaded
  • [ INFO] [1575371919.261510302]: Plugin setpoint_trajectory initialized
  • [ INFO] [1575371919.262125192]: Plugin setpoint_velocity loaded
  • [ INFO] [1575371919.278658007]: Plugin setpoint_velocity initialized
  • [ INFO] [1575371919.279859341]: Plugin sys_status loaded
  • [ INFO] [1575371919.307175110]: Plugin sys_status initialized
  • [ INFO] [1575371919.308086294]: Plugin sys_time loaded
  • [ INFO] [1575371919.319972895]: TM: Timesync mode: MAVLINK
  • [ INFO] [1575371919.324053655]: Plugin sys_time initialized
  • [ INFO] [1575371919.324787575]: Plugin trajectory loaded
  • [ INFO] [1575371919.345637097]: Plugin trajectory initialized
  • [ INFO] [1575371919.346560472]: Plugin vfr_hud loaded
  • [ INFO] [1575371919.349068667]: Plugin vfr_hud initialized
  • [ INFO] [1575371919.349268553]: Plugin vibration blacklisted
  • [ INFO] [1575371919.349832568]: Plugin vision_pose_estimate loaded
  • [ INFO] [1575371919.366850684]: Plugin vision_pose_estimate initialized
  • [ INFO] [1575371919.367271639]: Plugin vision_speed_estimate loaded
  • [ INFO] [1575371919.375466757]: Plugin vision_speed_estimate initialized
  • [ INFO] [1575371919.376295452]: Plugin waypoint loaded
  • [ INFO] [1575371919.387441606]: Plugin waypoint initialized
  • [ INFO] [1575371919.387652083]: Plugin wheel_odometry blacklisted
  • [ INFO] [1575371919.388259390]: Plugin wind_estimation loaded
  • [ INFO] [1575371919.390697255]: Plugin wind_estimation initialized
  • [ INFO] [1575371919.391405161]: Autostarting mavlink via USB on PX4
  • [ INFO] [1575371919.392222241]: Built-in SIMD instructions: ARM NEON
  • [ INFO] [1575371919.392707414]: Built-in MAVLink package version: 2019.11.11
  • [ INFO] [1575371919.393094324]: Known MAVLink dialects: common ardupilotmega ASLUAV autoquad icarous matrixpilot paparazzi slugs standard uAvionix ualberta
  • [ INFO] [1575371919.393653795]: MAVROS started. MY ID 1.240, TARGET ID 1.1

But I'm not getting the Heartbeat CON: Got HEARTBEAT I am using a Jetson TX2 and I have already installed ROS and MAVROS. I have the pixhawk 4 connected to Jetson via Telem port 2. I don’t want to use APSync, I'm using PX4. I want to run a test in my own drone that I have. Please, I ask for help to the community.

edit retag flag offensive close merge delete

Comments

did you set the px4 baud rate to 921600?

hamid gravatar imagehamid ( 2019-12-05 03:12:45 -0600 )edit

The baud-rate is 115200 because the TX2 only can support baud-rate to 115200, btw I'm using the TX2 with the Orbitty carrier board. I realize that there is a problem with the TX2. I don't know what to do...

subarashi gravatar imagesubarashi ( 2019-12-05 03:16:23 -0600 )edit

I used tx2 with a j120 carrier board and connected pix4 v2 through serial 5 with 921600 baud rate and there is no problem. did you install your specific version of tx2 linux for the carrier board?

hamid gravatar imagehamid ( 2019-12-05 03:22:36 -0600 )edit

Hello! thanks for your reply. Where I find serial 5? Now i'm workin with the devkit of TX2 to see if the problem was the orbitty. the PX4 is already setup. In the TX2 i'm running roslaunch mavros px4.launch fcu_url:="/dev/ttyTHS2:921600" gcs_url:="udp://14401@my_ip_TX2:14401"

subarashi gravatar imagesubarashi ( 2019-12-05 03:29:05 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-05 04:10:58 -0600

hamid gravatar image

from the manual in this link you must use /dev/ttyS0 or /dev/ttyTHS2 . /dev/ttyTHS1 is not aviliable. image description

edit flag offensive delete link more

Comments

I'm using /dev/ttyTHS2 but it seems not working...

subarashi gravatar imagesubarashi ( 2019-12-05 07:05:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-12-04 01:01:09 -0600

Seen: 14 times

Last updated: yesterday