Ask Your Question
0

Problems with roslaunch bringup Kinova Jaco arms

asked 2019-11-27 07:15:55 -0600

updated 2019-11-27 07:21:25 -0600

gvdhoorn gravatar image

Hi. I'm running Ubuntu 16.04 and ROS Kinetic. I recently upgraded from 14.04 and Indigo. Everything worked fine before, but now, when I try to launch my Kinova Jaco arms, I'm getting an error and I don't understand how to fix it. I've never gotten an error like this before, and I tried googling but I can't seem to find out what to do to fix this. Any help you can provide would be very greatly appreciated! Thanks very much!

The command I run :

roslaunch kinova_bringup kinova_robot.launch kinova_robotType:=j2n6s300 kinova_robotName:=left kinova_robotSerial:=PJ00900006WO5044820

The Error I get

PARAMETERS
 * /kinova_number_of_robots: 2
 * /kinova_robots: [{'serial': 'PJ00...
 * /left_driver/connection_type: USB
 * /left_driver/ethernet/local_broadcast_port: 25025
 * /left_driver/ethernet/local_cmd_port: 25000
 * /left_driver/ethernet/local_machine_IP: 192.168.100.100
 * /left_driver/ethernet/subnet_mask: 255.255.255.0
 * /left_driver/jointSpeedLimitParameter1: 10
 * /left_driver/jointSpeedLimitParameter2: 20
 * /left_driver/robot_name: left
 * /left_driver/robot_type: j2n6s300
 * /left_driver/serial_number: PJ00900006WO5044820
 * /left_driver/torque_parameters/publish_torque_with_gravity_compensation: False
 * /left_driver/torque_parameters/use_estimated_COM_parameters: False
 * /left_driver/use_jaco_v1_fingers: False
 * /robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /
    left_driver (kinova_driver/kinova_arm_driver)
    left_state_publisher (robot_state_publisher/robot_state_publisher)

ROS_MASTER_URI=http://localhost:11311

process[left_driver-1]: started with pid [3364]
process[left_state_publisher-2]: started with pid [3365]
[ INFO] [1574859834.374096419]: kinova_robotType is j2n6s300.
[ INFO] [1574859834.375342370]: kinova_robotName is left.
[FATAL] [1574859834.378008786]: USBCommandLayerUbuntu.so: cannot open shared object file: No such file or directory
kinova_arm_driver: /home/alexis/catkin_ws/src/kinova-ros/kinova_driver/src/kinova_api.cpp:26: void* kinova::KinovaAPI::initCommandLayerFunction(const char*): Assertion `function_pointer != NULL' failed.
[left_driver-1] process has died [pid 3364, exit code -6, cmd /home/alexis/catkin_ws/devel/lib/kinova_driver/kinova_arm_driver j2n6s300 __name:=left_driver __log:=/home/alexis/.ros/log/467f01d0-1116-11ea-8784-8ca982d60e8e/left_driver-1.log].
log file: /home/alexis/.ros/log/467f01d0-1116-11ea-8784-8ca982d60e8e/left_driver-1*.log
edit retag flag offensive close merge delete

Comments

1

As to your problem: have you rebuilt the workspace after upgrading (ie: remove the build and devel folders and run catkin_make (or catkin build) again)?

Looking at the readme it appears things should-just-work on Kinetic.

The USBCommandLayerUbuntu.so is a library that is distributed with kinova_driver (here) and installed here.

There don't appear to be any specific build or installation instructions, so I assume it should work in both the devel as well as the install space.

The error essentially tells you that the search path for libraries does not include the location that holds the .so file(s).

gvdhoorn gravatar imagegvdhoorn ( 2019-11-27 07:22:51 -0600 )edit

Yes, I did rebuild the workspace after upgrading

blockale23 gravatar imageblockale23 ( 2019-11-27 07:30:59 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-27 08:50:33 -0600

It seemed there were multiple issues. First, for some reason the library you showed me was missing in my folder. I ended up re-installing kinova-ros completely to ensure there weren't any other things missing. That fixed some problems but not all. Then, I eliminated any specifications of the arm (name, serial number) and I was finally able to bring up one arm. Then when I tried again to bringup a specific arm using the name and serial number it all of a sudden worked. Strange. But thank you very much for your help in solving this issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-11-27 07:15:55 -0600

Seen: 19 times

Last updated: Nov 27