Ask Your Question
0

roscore on multimachine issue

asked 2019-11-20 05:48:51 -0600

Aviad gravatar image

Hello,

Until yesterday my multi machines works well. I have two computers, one master and one slave. Today, I tried to use chrony for use the same clock in the both computer. I did the tests in the master machine. Since then the slave can not communicate to the master which is run with roscore but in the other side, if the roscore is run in the "slave" the "master" can communicate to it.

I get this error in the slave machine when I try to run roscore:

WARNING: ROS_MASTER_URI host is not set to this machine

Someone has any idea what happens?

Thanks, Aviad

edit retag flag offensive close merge delete

Comments

It would probably be a good idea to show values of ROS_MASTER_URI, ROS_IP, ROS_HOSTNAME and the hostnames and IP addresses for all involved hosts.

gvdhoorn gravatar imagegvdhoorn ( 2019-11-20 06:13:46 -0600 )edit

In the master machine:

ROS_IP: 192.168.16.105

in the slave machine:

ROS_IP: 192.168.16.100

ROS_MASTER_URI: http;//192.168.16.105:11311

Again. It worked fine until I tried to work with chrony. I used this commands if it could helps:

firewall-cmd --zone=public --add-port=123/udp

firewall-cmd --zone=public --add-port=323/udp
Aviad gravatar imageAviad ( 2019-11-20 07:09:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-11-20 07:35:01 -0600

Aviad gravatar image

So, the problem was relevant to the command lines above really. I just remove the firewalld pkg and it is working now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-20 05:48:51 -0600

Seen: 22 times

Last updated: Nov 20