Ask Your Question
0

Data from Optitrack is not getting streamed properly to vrpn_client_ros

asked 2019-11-18 12:22:48 -0600

haneesh gravatar image

i'm currently using optitrack motive 1.10.1 version for tracking 3 UAVs. i'm using vrpn streaming to stream the data. im connecting the host pc (on which motive is running) to router using lan and connecting the pc running ros to the router's wifi. while im running the sample.launch in vrpn_client_ros package, im getting data slowly at times and quick at times. i couldn't figure out if this is due to pc issue or router issue or motive issue. i would like to know what changes in code needs to be made so that if data/packet doesn't come for any instant then that instant could be displayed. so that i could know the trend of data getting lost

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-18 13:07:20 -0600

gvdhoorn gravatar image

First thing to try is to connect everything using cables. Getting data in bursts ("slowly at times and quick at times") seems to point to networking issues. Take out the wireless segment and see whether that improves things.

edit flag offensive delete link more

Comments

@gvdhoorn , thanks .That worked out well

haneesh gravatar imagehaneesh ( 2019-11-19 06:30:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-18 12:22:48 -0600

Seen: 29 times

Last updated: Nov 18