Ask Your Question
3

Core dump at Gazebo startup

asked 2012-05-10 22:42:37 -0500

Charuvahan gravatar image

I try the following terminal command.

roslaunch gazebo_worlds empty_world.launch

I get the following error

Illegal instruction (core dumped)

[empty_world_server-1] process has died [pid 3395, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=empty_world_server __log:=/home/chartoin/.ros/log/26f27722-9b42-11e1-b127-3859f9dbd9aa/empty_world_server-1.log].

log file: /home/chartoin/.ros/log/26f27722-9b42-11e1-b127-3859f9dbd9aa/empty_world_server-1*.log

/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 3406 Illegal instruction (core dumped) rospack find gazebo/gazebo/bin/gzclient -g rospack find gazebo/lib/libgazebo_ros_paths_plugin.so

[gazebo_gui-2] process has died [pid 3403, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/chartoin/.ros/log/26f27722-9b42-11e1-b127-3859f9dbd9aa/gazebo_gui-2.log].

log file: /home/chartoin/.ros/log/26f27722-9b42-11e1-b127-3859f9dbd9aa/gazebo_gui-2*.log

This error happens on a Thinkpad x120e laptop with an AMD Fushion e 350 APU. The same command works well when I use a Dell XPS 15 laptop with intel processor and nvidia graphics card.

edit retag flag offensive close merge delete

Comments

I get this on a Ubuntu 12.04 system and Nvidia graphics card (GF110 [GeForce GTX 560 Ti] (rev a1) using the 64-bit 295.41 dev drivers). But it works on my 12.04 laptop with an AMD card (ATI RV730 XT [Mobility Radeon HD 4670 ). Update - no it crashes the same way after a few minutes.

lucasw gravatar image lucasw  ( 2012-06-07 05:48:39 -0500 )edit

I get this on a Ubuntu 12.04 system and Nvidia graphics card (GF110 [GeForce GTX 560 Ti] (rev a1) using the 64-bit 295.41 dev drivers).

lucasw gravatar image lucasw  ( 2012-06-07 05:48:42 -0500 )edit

@lucasw do you think it's got to do with the drivers? been following the issue on this thread: http://answers.ros.org/question/33449/gazebo-illegal-instruction

kshitij gravatar image kshitij  ( 2012-06-12 10:45:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-10 04:24:50 -0500

Chade gravatar image

updated 2012-07-10 05:42:12 -0500

I get the same Error with Ubuntu 12.04 64bit and ROS Fuerte. On the same laptop with Ubuntu 11.10 64bit and ROS Electric everything works like a charm, so if there have not been any major changes to the graphics driver in Ubuntu 12.04 I would say it's a problem with gazebo.

As stated in this thread Klick it may relate to issues with gazebo which should be solved with an update, but my system is up-to-date and I still get the same error.

Update:

Created an remastered Ubuntu distribution with ROS and everything of my current system. When I boot from live usb stick and run gazebo on my second notebook (Intel graphics card) everything is just fine... So perhaps back to an hardware issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-05-10 22:42:37 -0500

Seen: 942 times

Last updated: Jul 10 '12