Is it posible to use move_base for an omnidirectional robots?

asked 2019-11-09 03:34:55 -0600

Chamith gravatar image

I am trying to use move_base package to control the omni-directional robot, but in the base_local_planner_params.yaml file, i set the holonomic_robot:true, but my system (/cmd_vel) doesn't get any output in y directions. Does anybody can help me in this?

base_local_planner_params.yaml

TrajectoryPlannerROS:
  max_vel_x: 0.3
  min_vel_x: 0.05
  max_vel_y: 0.3
  min_vel_y: 0.05
  max_vel_theta: 0.9
  min_in_place_vel_theta: 0.7
  acc_lim_theta: 2.0
  acc_lim_x: 2
  acc_lim_y: 2
  holonomic_robot: true
  yaw_goal_tolerance: 2.0
  xy_goal_tolerance: 0.3
  meter_scoring: true
  recovery_behavior_enabled: false
  clearing_rotation_allowed: false

costmap_common_params.yaml

#This file contains common configuration options for the two costmaps used in the navigation stack for more details on the parameters in this file, and a full list of the parameters used by the costmaps, please see http://www.ros.org/wiki/costmap_2d

#For this example we'll configure the costmap in voxel-grid mode
map_type: costmap  

    #Set the tolerance we're willing to have for tf transforms
    transform_tolerance: 2.0
    obstacle_range: 3.5
    raytrace_range: 4.0

    footprint: [[-0.127, -0.127], [-0.18, 0.0], [-0.127, 0.127], [0.0, 0.18], [0.127, 0.127], [0.18, 0.0], [0.127, -0.127], [0.0, -0.18]]
    #robot_radius: 0.18



footprint_padding: 0.03

#Cost function parameters
inflation_radius: 0.55
cost_scaling_factor: 10.0

#The cost at which a cell is considered an obstacle when a map is read from the map_server
lethal_cost_threshold: 100


#Configuration for the sensors that the costmap will use to update a map
observation_sources: laser_scan_sensor
laser_scan_sensor: {sensor_frame: base_link, data_type: LaserScan, topic: /scan, marking: true, clearing: true, max_obstacle_height: 20.0, min_obstacle_height: 0.0}

global_costmap_params.yaml

global_costmap:

      global_frame: map
      robot_base_frame: base_link
      update_frequency: 2.0
      publish_frequency: 2.0
      static_map: true
      rolling_window: true

      width: 100.0
      height: 100.0
      resolution: 0.05

local_costmap_params.yaml

local_costmap:

  global_frame: map
  robot_base_frame: base_link
  update_frequency: 5.0
  publish_frequency: 5.0
  static_map: false
  rolling_window: true
  width: 1.5
  height: 1.5
  resolution: 0.01
edit retag flag offensive close merge delete

Comments

Hi,

Maybe is not a problem in the move_base but in your set up. Ca you provide the tf tree and the rqt_graph output? To be sure you have all tf properly set and all nodes and topics properly connected.

In the case all is properly set when you set up in the base_local_planner config file the holonomic_robot param to true you also have the y_vels to set the strafing velocities.

Furthermore, maybe you goal tolerance is to high when you input a certain goal.

Also, you can try different approaches like this.

Weasfas gravatar imageWeasfas ( 2019-11-14 09:46:46 -0600 )edit