Ask Your Question
0

Disable any output of roscore

asked 2019-11-07 03:07:34 -0600

chris93 gravatar image

I have already seen many threads addressing this topic, but they seem to be slightly different. I am working on melodic and Ubuntu 18.04.

What I have tried so far:

  • set log4j.threshold=OFF in rosconsole.config
  • set export ROSOUT_DISABLE_FILE_LOGGING=True in .bashrc
  • set ' param name="/rosout/omit_topics" value="true" ' in the launchfile

This does indeed turn of any INFO/WARN/ERROR but keeps the summary at the very beginning, when launching the roscore/launchfile. I need to be able to call

roscore

without any output in the screen. Ideally not even process[xyz]: starting or killing on exit output. The reason is, that I start and restart multiple instances, which basically makes my own logging disappear in a bunch of rosoutput.

Cheers

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-07 04:12:14 -0600

chris93 gravatar image

For now I went with the ugly way and modified some files in

/opt/ros/melodic/lib/python2.7/dist-packages/roslaunch/

The summary is printed in parent.py and most of the other stuff by the functions printlog() and printlog_bold() in core.py. The rest is found in launch.py and __init__.py.

Anyway I will leave this post open, since the solution is not pretty and applies to all the nodes running on the computer.
Would be nice if someone has a better solution, even though the code does not look like as hiding the summary by config file is considered.

Cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-11-07 03:07:34 -0600

Seen: 10 times

Last updated: Nov 07